VNC-Server 2.1: Keyboard Loading/Non-US Keyboards

When i set “-keyBoardLoading Y” and start the server the log-file show follwing:

2006-12-13 14:45:03 +0100 Starting Vine Server Version 2.1
-rfbport 0 -desktop zimmw (zimmwmac.local) -alwaysshared -protocol 3.7 -restartonuserswitch N -keyboardLoading N -pressModsForKeys N -rendezvous N -rfbauth /Applications/Utilities/Vine -keyboardLoading Y

2006-12-13 14:45:03.841 OSXvnc-server[16996] Arguments: -rfbport 0 -desktop zimmw (zimmwmac.local) -alwaysshared -protocol 3.7 -restartonuserswitch N -keyboardLoading N -pressModsForKeys N -rendezvous N -rfbauth /Applications/Utilities/Vine -keyboardLoading Y
2006-12-13 14:45:03.841 OSXvnc-server[16996] Forcing: RFB 003.007
2006-12-13 14:45:03.850 OSXvnc-server[16996] Main Bundle: /Applications/Utilities/Vine
2006-12-13 14:45:03.850 OSXvnc-server[16996] Loading Bundle /Applications/Utilities/Vine
2006-12-13 14:45:03.852 OSXvnc-server[16996] Keyboard Loading - Disabled
2006-12-13 14:45:03.852 OSXvnc-server[16996] Press Modifiers For Character - Disabled
2006-12-13 14:45:03.882 OSXvnc-server[16996] Running in Little Endian
2006-12-13 14:45:03.883 OSXvnc-server[16996] Waiting for clients
2006-12-13 14:45:03.883 OSXvnc-server[16996] Rendezvous(_rfb._tcp) - Disabled
2006-12-13 14:45:03.883 OSXvnc-server[16996] Rendezvous(_vnc._tcp) - Disabled
2006-12-13 14:45:03.884 OSXvnc-server[16996] IPv6: Started Listener Thread on port 5901
2006-12-13 14:45:03.885 OSXvnc-server[16996] Started Listener Thread on port 5901

If i connect with an VNC-Viewer and select an opened terminal, the keyboard strokes us-keys.

I?ve installed MacOSX 10.4.8 with German localize.

How can i set up the server correct, so that i can use in the viewer a german 105-keyboard ???

Have anyone a little HOW-TO?

Thanks for all answers.

greetings frank

Currently Vine Server doesn’t have an easy way to reconfigure it’s keyboard settings.

We hope to add additional support for this in the next release.

For now the best approach is to set the SERVER machine to be using the US-101 keyboard and then use special keys to type extended latin charaters.

Like “Option-U u” to get a ?.

Thanks for the fast answer.
So i?ll wait for that.

my conifg example

server 2.1 on MacOSX 10.4.8 with Mac-Keyboard
client RealVNC on WinXP with 105-Keyboard German layout.

so long frank : :frowning: