VNC protocol mismatch error

I am able to connect using GUI in eggplant , i want to test working from command line.
I have floating license (Trial)

  1. i run command ./runscript /home/yummi/Documents/eggplant.suite/Scripts/launch.script -host -port 5900 -ReportFailures = yes
  2. then i run real vnc server on mobile
  3. I get connection refused error and pop up saying VNC protocol mismatch

device : HTC sensation running android and RCS – Cyanogen
host OS - Ubuntu
complete error log :
Fontconfig warning: “/etc/fonts/conf.d/11-lcd-filter-lcddefault.conf”, line 9: invalid constant used : lcddefault
Fontconfig warning: “/etc/fonts/conf.d/53-monospace-lcd-filter.conf”, line 17: invalid constant used : lcdlegacy
2012-04-23 07:03:13.137 Eggplant[14592] FineReader non-expiring license. Unlimited Usage
2012-04-23 07:03:24.020 Eggplant[14592] Approved License: Name = , Remark = , Serial = 18334, Users = 1
Eggplant (11.22-1203121901) running in CLI mode on Host:0.
2012-04-23 07:03:24.329 Eggplant[14592] Initialized VNCViewer SDK
2012-04-23 07:03:25.675 Eggplant[14592] vncErrorCallback: VNCViewerErrorConnectionRefused - The server host refused the TCP connection.
WARNING thread 0x96e1204 terminated without calling +exit!
2012-04-23 07:03:29.276 Eggplant[14592] Error - Unable to Connect To (0)
Connection Failed: Unable to connect to Server: on port:5900
Unable to Contact Server: (Connection refused)

2012-04-23 07:03:29.397 Eggplant[14592] -[GSLayoutManager(layout) textContainerForGlyphAtIndex:effectiveRange:withoutAdditionalLayout:]: can’t find text container for glyph (internal error)
2012-04-23 07:03:30.090 Eggplant[14592] reported exception - NAME:Script Failed REASON:No Remote Connection:
click Error - Remote Connection Unavailable INFO:{CallStack = ("(Handler:“launch”, Line:“1”, MeObjectID:"/home/yummi/Documents/eggplant.suite/Scripts/launch.script", MessageName:“on_launch”, MessageType:“Command”, objectType:“SenseTalkFrame”, RepeatIndex:“0”, ScriptObjectID:"/home/yummi/Documents/eggplant.suite/Scripts/launch.script", TryDepth:“0”)"); LogMessage = “Remote Connection Unavailable”; OtherButton = “”; ScriptError = “Runtime Error at line 1: No Remote Connection - click Error - Remote Connection Unavailable”; }
2012-04-23 07:03:30.630 Eggplant[14592] Completed EggplantTestScript eggplant.suite - launch.script
2012-04-23 07:03:30.631 Eggplant[14592] Exception running :
Invalid File: Invalid file type or file not found (yes)

EggPlant tries to negotiate an appropriate connection protocol. When you run from the command line there is currently no way to tell it that it should use a mobile connection type (that flag will be available in the next release) so it starts with a standard RFB 3.8 negotiation, but some mobile servers really don’t like that and just refuse all subsequent connection attempts, even when it gets around to trying the mobile protocols.

Thanks for ur reply…
I had used cyanogeon RCS and real mobile VNC server last week and connection was fine…
I downloaded latest version of cyanogeon RCS and real mobile VNC server today and it shows protocol mismatch error on my android (HTC).
Now am unable to connect to eggplant using GUI also

Can you guide in setting up RCS / Mobile VNC and connection am using 11_3 beta software

Within the eggPlant GUI please be sure to select Connection Type: MOBILE when connecting to RealVNC server on Android. If you have previously try to connect with automatic or standard then make sure to restart your VNC server.