Vine Viewer not handling VPN routing

I am currently logged into a SOHO network on I have a VPN established through the normal Apple method (System Preferences / Network pane) to a remote system whose addresses are on The services are ordered such that the VPN appears first.

Every other tool on my Mac (Safari, Network Utility, ping, etc.) immediately routes requests to correctly. However, Vine Server refuses to open a VNC connection to this address, claiming that the network is unreachable. OS X screen sharing has no trouble opening a session to this same machine.

I tried quitting and restarting Vine Server, in case it fetched routing rules only on startup, but it didn’t resolve the problem.

There shouldn’t be anything special or abnormal about the way Vine Viewer does it’s routing, it’s relying entirely on standard calls to open ports.

First, do a check with your browser by hitting: and see if you get the RFB handshake message (RFB 003.XXX). If not then it’s not anything in Vine, it’s something else.

You mention Using the OS X screen sharing – is that connecting to Vine Server (which it should be able to)? Or to Apple’s server?

If you configure Apple’s server to allow VNC then can you connect with Vine Viewer?

Right, my own thought was that you would have to really go out of your way to create this type of failure when all other tools are succeeding.

I used Apple’s screen sharing by launching the Screen Sharing tool and then typing in the IP address of the target machine, then its password. Worked fine.

Sorry, I am no longer at the location outside my own network, so I can’t do the browser test you requested. But I did call up my printer’s configuration screen on my browser at the time, and it was in the same IP subnet (it didn’t have an open VNC port, obviously).