hi :slight_smile:

i use Vine Server with “Vine\” in a script

why doesn’t it work more ?
do you plan to forget it ?

(i’m under Mac OS X 10.4.11,
does someone succeed in make it run ?)

i join a picture of what i get in chicken

btw, “Vine\ -h” speaks about mac os x 10.2, whereas you don’t suport mac os x 10.2 more
so i suppose that it’s not up to date

it would be very nice if you could update this documentation, and make it a little bit clearer please :slight_smile:
(i don’t know always what “flag” i’m allowed to set)

Running it from the command line should work just fine. Are you sure you are connecting to the same port number that OSXvnc-server is running on? When the server starts up it provides information about how it is running, including the port number it is listening on.

Although the Vine Server GUI interface requires Mac OS X 10.3.9, when run directly from the command line the OSXvnc-server still supports older versions going back to 10.1 I believe (so the information about 10.2 is still valid). We should probably update the documentation to make that more clear.

yes, i’m sure i’m connecting to OSXvnc-server :
i’ve checked port numbers,
i get a different error msg in Chicken when OSXvnc-server is not running,
and OSXvnc-server prints sth when i try to connect to it

did you try Chicken of the VNC itself, not only Vine Viewer ?
maybe you are on 10.5 and this problem happens only on 10.4 ?

ok, cool :slight_smile: :slight_smile:
good news :slight_smile:

thank you :slight_smile:

When running the command line you need to either pass in a password file or the -rfbnoauth flag to allow logging in without a password.

thank you very much, it works :slight_smile: :slight_smile:

the -rfbnoauth flag is new, isn’t it ?
is there a possible usage of OSXvnc-server without -rfbnoauth nor -rfbauth nor -connectHost ?
if not, you should print an explicit error message and quit, rather than let it running :slight_smile:

but i still can’t type “i” nor “;” with a french keyboard on both sides and “-keyboardLoading y”

btw, why hadn’t i received any notification for your post ? is it right ?

Yes that is a new security precaution. It does log a warning.

It doesn’t quit because you can still initiate reverse connect calls to the process even if you didn’t pass one on the initial command line (that’s how it works from the GUI application to the underlying server).

If you have set it up (under Your Profile) you should definitely receive a notification when someone replies.

On the French letter “i” are you using the GUI or just the CLI? First we should see if you can get it working with the GUI – try the various settings under Devices->Keyboard and see if any of them work for you.

ah ?
i don’t see anything :

$ thomas/Vine\ -rfbport 5902

  • ‘thomas/Vine’ -rfbport 5902
    2008-11-09 04:03:24.931 OSXvnc-server[14837] Arguments: -rfbport 5902
    2008-11-09 04:03:24.934 OSXvnc-server[14837] Main Bundle: /Users/silodebeaumont/thomas/Vine
    2008-11-09 04:03:24.938 OSXvnc-server[14837] Loading Bundle /Users/silodebeaumont/thomas/Vine
    2008-11-09 04:03:24.946 OSXvnc-server[14837] Loading Bundle /Users/silodebeaumont/thomas/Vine
    2008-11-09 04:03:24.961 OSXvnc-server[14837] Running in Big Endian
    2008-11-09 04:03:24.962 OSXvnc-server[14837] Pasteboard Inaccessible - Pasteboard sharing disabled
    2008-11-09 04:03:24.965 OSXvnc-server[14837] Waiting for clients
    2008-11-09 04:03:24.965 OSXvnc-server[14837] Using Private Event Source
    2008-11-09 04:03:24.968 OSXvnc-server[14837] Unable to get session dictionary.
    2008-11-09 04:03:24.968 OSXvnc-server[14837] Using Dynamic Event Tap – Session for off-screen user
    2008-11-09 04:03:24.990 OSXvnc-server[14837] Registering Bonjour Service(_rfb._tcp.) - Silo-de-Beaumont.local
    2008-11-09 04:03:24.993 OSXvnc-server[14837] IPv6: Started Listener Thread on port 5902
    2008-11-09 04:03:24.994 OSXvnc-server[14837] Started Listener Thread on port 5902

even if there is sth that i don’t understand, i suggest you to put sth more human readable like “you seem to don’t want to request authentication. if it’s right, you must specify -rfbnoauth”

btw, why not let -localhost not require -rfbnoauth ?

ok :slight_smile:

ok, i received a notification for your last msg :slight_smile:
maybe a msg which has been lost …

i want to use only the CLI but i tried both,
and when i reported it on the other thread, i hadn’t succeed in run Vine Server by CLI yet (i just succeed today thanks to you :slight_smile: ), so i was using the GUI

with “us” or “unicode” keyboard, i have not tried all the keys but it seems to work
but obviously it was the us keyboard

i don’t see any difference betwin “user session events” and “hardware events”

on both sides : mac os x 10.4.11 and french keyboard
i have a macbook with an intel processor, and the remote computer is an emac with a ppc processor
do you need sth else ? :slight_smile: