Vine server 3.12 on OSX Server 10.6.6 fuzzy screen

Hi! I ws wondering, I have Xserve running SL Server 10.6.6, and Vine server 3.12 (from I don’t have “screen sharing” or “remote management” enabled in the “System Preferences” --> “Internet & Wireless” --> “Sharing”

I have a shared account that users use to vnc on port 5900, that users use to login and fast switch to their login, and start Vine, and get their vnc port, so they have their own vnc session…

It looks like that after a couple new sessions are created on different ports (e.g. 5901, 5902, 5902, etc), if then I try to vncviewer to 5900 again, that session shows on my client as fuzzy lines, like a screen of an old analog tv with bad reception…! The other sessions already established for the other users on different ports were still functional…but the rate that the port 5900’s session becomes fuzzy feels random…

The only way to solve this is to reboot the whole system, but this is a situation where Vine server isn’t useful…haven’t changed any Vine settings, just ran the defaults…

test:~ user$ uname -a
Darwin test 10.6.0 Darwin Kernel Version 10.6.0: Wed Nov 10 18:11:58 PST 2010; root:xnu-1504.9.26~3/RELEASE_X86_64 x86_64
test:~ user$

Has anyone seen this? any ideas?

Thank you!
Xserve, Mac OS X (10.6.6)

Well that’s a new one. Can you post a screen shot? I’m not sure if your scan-lines are messed up (which indicates an error with getting the proper screen size) or if it’s something even more bizarre.

Hi! will screen capture next time it happens, since I just rebooted system…! thanks!

Here’s what I am referring to for fuzzy screen, it just happened again. Any suggestions? thanks!

Ok that is indeed a problem with it having the wrong screen resolution.

Of course it’s pretty tricky to change it when the screen looks like that. You might be able to use an open source utility called displayutil that is available out there.

It might also help to forcibly shell in and restart the server (which should pick up the current screen resolution.

Hi! I’m a little bit lost, how do you suggest using displayutil in conjunction with Vine server?

on regular unix, you could use vncserver, and set the resolution of the vncsession…but I don’t see that option in Vine server gui…

Also, is there any way to stop Vine from the command line, so that I don’t have to keep rebooting the server? what’s the correct way to start Vine from the cli? since I don’t have physical access to the Xserve…


So the reason you can’t set the resolution when launching Vine is that, unlike XWindows, the user session needs to already exist and so Vine Server just uses the resolution of the currently running GUI session.

displayutil is just a simple CLI tool that let’s you change the GUI’s resolution – it’s just like picking it from the SystemPreferences, but can be done using the command line.

With the System Server you should be able to kill the osxvnc-server process and it should be restarted for you.

Within the there is a link to the osxvnc-server executable, that can also be started from command line. The arguments are documented in the Manual or you can do -h to see a list.

Hi, I work with unix-support and I searched all over the web for a place to download displayutil and it appears to no longer be available. Any ideas where I can get a copy?

What confuses me about the display being the issue is that every session has taken place from the same laptop and MAC OS. I connect to the 5900 port and log in a new user. The VNC session goes away, so I start a new one on port 5900 and then I see the fuzzy screen. Other than switching users nothing has changed. At one point I had 7 users logged on and then I saw the problem when I tried to connect the 8th user. Now I see it when I simply try to connect a 2nd user. The only thing changing is who is connected to the MAC OS desktop.


I have attached a copy here – I can’t vouch for it’s effectiveness on all machines or OS versions, but it worked on my laptop.

I think the factor at play is whether the new user who is logging in personally has specified a different resolution for HIS user session (and when I say specified I think it remembers it from the previous session).

I believe that when this occurs it can create the problem you are seeing – I think if all users were normalized to the same standard resolution you wouldn’t run into this problem.


Thanks for the file. I downloaded and placed on the Mac OS box. However, I am not sure if I am using correctly or not. Here is what I see…

I ssh to the box as the initial user (UserA) and execute the command using -l to see the list of display modes and get a list:

ucelfaosx001:displayutil-0.03 UserA$ ./displayutil -l
1104977153 0 1x1 8
1104977153 0 1x1 16
1104977153 0 1x1 32
1104977153 0 800x600 8
1104977153 0 800x600 16
1104977153 0 800x600 32
1104977153 0 1024x768 8
1104977153 0 1024x768 16
1104977153 0 1024x768 32
1104977153 0 1280x1024 8
1104977153 0 1280x1024 16
1104977153 0 1280x1024 32
1104977153 0 1680x1050 8
1104977153 0 1680x1050 16
1104977153 0 1680x1050 32
1104977153 0 1280x1024 32

I then connect to the box as the user I tried to log into the server via vnc (UserB) and execute the same command and get this (no listing):

ucelfaosx001:displayutil-0.03 UserB$ ./displayutil -l
ucelfaosx001:displayutil-0.03 UserB$

If I try setting the resolution I get the following:

ucelfaosx001:displayutil-0.03 UserB$ ./displayutil -r1680x1050
Not an available mode

Am I doing something wrong?


You might need to run that as root.