Vine Server 3.1 shuts down during startup


i am using a macbook with OSX 10.5.8 installed and am trying to connect to this macbook using an android cellphone from htc with remote vnc pro.

it worked a couple of times before, but then i changed my isp an got a new modem/router since then i am having problems connecting.
though i dont think it should be having any effect.

everytime i try to start vineserver the process stops and i get the message “Das Programm ‘Vine Server’ wurde unerwartet beendet” or roughly translated “the program was unexpectedly shut down”. as i said, i didnt have the problem before and vineserver 2.1 works as well.

with 2.1 i haven’t figured out the setup for my cellphone yet

Try downloading and reinstalling the application. There’s no inherent problem with Vine on any version of 10.5.

i think i am up to 10 re-downloads so far

since it worked before, i know it’s possible somehow.

but there seems to be something, that keeps vine from loading.
and i would like to find out what that is :wink:

Check the Console for error messages. There is no known issue that would prevent the application from launching. We run it all the time and it has run on every release of Mac OS, up to and including 10.6.5.

hmm, i copied the first few lines maybe you can make some sense of it.

Process: Vine Server [6404]
Path: /Applications/Vine Server
Identifier: com.redstonesoftware.VineServer
Version: 3.11 (1031)
Code Type: X86 (Native)
Parent Process: launchd [67]

Interval Since Last Report: 33398 sec
Crashes Since Last Report: 2
Per-App Interval Since Last Report: 20 sec
Per-App Crashes Since Last Report: 2

Date/Time: 2010-11-24 00:48:12.949 +0100
OS Version: Mac OS X 10.5.8 (9L31a)
Report Version: 6
Anonymous UUID: F25D7112-780F-450C-90DD-CC2932470AD0

Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Application Specific Information:
*** Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘*** -[NSCFArray removeObjectAtIndex:]: mutating method sent to immutable object’

Thread 0 Crashed:
1 libobjc.A.dylib 0x9244be3b objc_exception_throw + 40
2 0x916bcdcb +[NSException raise:format:arguments:] + 155
3 0x916bce0a +[NSException raise:format:] + 58
4 0x95e1d834 -[NSCFArray removeObjectAtIndex:] + 212
5 0x916b5028 -[NSMutableArray removeObject:range:identical:] + 456
6 0x916b54c0 -[NSMutableArray removeObject:] + 96
7 …redstonesoftware.VineServer 0x00002a06 0x1000 + 6662
8 …redstonesoftware.VineServer 0x00003403 0x1000 + 9219
9 0x916cb7f5 -[NSSet makeObjectsPerformSelector:] + 181
10 0x93333d8e -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1533
11 0x93329fba loadNib + 264
12 0x9332991c +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 946
13 0x9332955f +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 171
14 0x9332949d +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 391
15 0x9332914c NSApplicationMain + 434
16 …redstonesoftware.VineServer 0x000020b6 0x1000 + 4278
17 …redstonesoftware.VineServer 0x00001fdd 0x1000 + 4061

there is more, but maybe this is enough already

installed beta 3.12 after i found that one, works fine now :slight_smile: