Vine Reconfiguration Issues, Settings not Applying

Just the other day I installed Vine Server (2.2) on a OS X Server (10.4.11) machine. I’d configured it for a standard password for login, but now need to reconfigure it for a new password as others need to use the machine and sharing the password is not an option.

I’ve tired reentering the password in the password field, then stopping/starting the services again and also rebooting but the initial password is the only password I can use to access the machine.

Anyone know what else is going on? Never had an issue with VNC servers (in the windows world) before…

I would guess it’s a situation where you configured a System Server (using the old password) and that is what you are running into.

Try disabling the System Server and then either restarting a System Server or only using the Application/Desktop Server.

How would one reset an old system server? forcing the display drop down to the 0 display number (from auto) displays the correct port I’m using (5900), but I get the error that “Vine Server can’t listen on the port. Probably because the OSXvnc server is already running as a startup item.”

I’m getting the above error even though I’m currently connected (connection was able to happen after deleting the /Library/StartupItems/OSXvnc folder and rebooting).

I would start by just removing the old system server – from the menu do File -> Stop System Server.

That should remove (and shutdown) any System Server. You might also want to make sure that you aren’t running ARD on port 5900 (with a VNC password set).


I am having a similar issue, I configured a system server and a “regular” connection with the same password and things worked fine. I tried changing both passwords (again to the same new password), restarted both servers and cannot connect, I get wrong password errors (either port)

Presently, the only way to connect is to have a blank system server password, clearly, I do not want to do this.

If I understand this correctly, the system server runs similar to a windows service, always runs in the background and initializes on startup.

If so, that is exactly what I want, can I run only this instance? And if so how can I resolve the password issue?

Any and all help will be greatly appreciated,

You can definitely run with only the System Server, which runs at startup and will restart if you switch users or log-in.

I would definitely disable your system server, then set a new password and then start the system server again. You should then be able to restart and connect with your new password.

Just to be certain if you are running on port 5900 – make sure that Apple’s ARD/Screen Sharing is turned off in System Preferences.

Thanks! I will try this