Typetext character translation error

characters are intermittently and randomly being translated from upper to lower case, from colon to semicolon, etc.

Testing Configuration:
My typical setup is to connect to a windows PC using VNC and then running the eggplant scripts. Both the PC and Mac are connected via a simple switch.

However I have recently tried to run my SUT in a windows Remote Desktop window on my PC to access a machine over a VPN connection. Now my PC and Mac are hooked up to a router, which in turn is connected to the internet.

My configuration looks like:
eggplant —VNC—>PC—RDC—>remote pc (accessed via vpn)

Now when I run my scripts I get characters being intermittenly translated incorrectly. The case of the letters gets switched, colons end up as semi-colons, and double quotes end up as single quotes. Except for the singleQuote/doubleQuote issue, the cases and colon/semicolon translation are off by 1 bit.

I have one other PC on the router…if I disconnect this pc the frequency of the translation errors is reduced; however they still occur.

I figure it must have something to do with either VNC/RDC interaction or router traffic (or both) causing some kind of translation error.

As a simple test I used typetext “aaAaa” and issue this from eggplant into a dos command on my remote desk top. The string that eventually arrives is a inconsitent variation of upper and lower case ‘a’(s).

Has anyone else ever had this problem?

Thanks in advance

In Eggplant’s Preferences, under Run Options / Keyboard is an option called “Send shift key down for capitals”. I wonder if you might try changing this setting to see if that has any impact for you?

All of the symptoms you’ve reported seem to point to the difference between the shift key being down or not, so this may change things for you.

I think you are right that it’s a timing interaction problem between VNC and WRD processes. As if the shift key were going down for the rest of the computer but not in time for the WRD to acknowledge it’s state.

You might also try increasing the next key delay in Eggplant preferences (by a full order of magnitude).

thanks for the tips.

I have tried the “send shift key down” approach, but it did not alleviate the problem.

I am going to try the “next key delay” approach and I will post back when I get the results.

again, thanks for the replies

I tried increase the NextKeyDelay and KeyDownDelay. The problem is not alleviated.

I will be trying to eliminate the RDC and trying VNC from the mac directly to the VM. Once I have tried this I will post the results