Trying to start, says Bad executable


i was trying to run vine server/viewer on my OSX10.4.1/x86 machine, but all i get is
bash: ./Vine Viewer: Bad executable (or shared library)
i have downloaded both server and viewer package several times, but it’s the same error message. anybody knows what could cause this?,

This error usually occurs when your download becomes munged and loses the symbolic link the underlying VNC server executable. This can happen if you are unpacking it on a Windows machine or you are copying it strangely (FTP or something).

Try downloading and unpacking VineServer directly on the machine that will be using it.

Downloaded, mounted, installed, ran, all worked while on a mac.

Yea, i thought it could be broken in download or something like that, that’s why i downloaded it several times. It was on the same machine i’m trying to run it.

How are you unpacking it?

With the default DiskImageMounter,

I would recommend this…

  1. launch /Applications/Utilties/
  2. Type in a shell terminal windows, “cd /tmp”
  3. Type “curl -O
  4. Type “open .”
  5. From Finder, double click the .dmg and do the Vine Install to /Applications (drag and drop), authenticate if needed, overwrite existing.
  6. Please verify here that this worked.

If that doesn’t work, then maybe you can provide an anonymous ftp site and I can drop it into that site for you.

Well the commands worked fine, but it still get Bad executable. i have also downloaded it with a linux box on another isp and put the dmg on a usb stick,… i don’t think it’s a download problem, can’t there be any other reason?

Hmm…that really is bizarre (and are you really running 10.4.1 or did you mean 10.4.10).

I would suggest starting totally from scratch, remove all instances of Vine from you Desktop,/Applications and the OSXvnc server from /Library/Startup. (Maybe even reboot).

Do a fresh download and actually just run Vine Server from the DMG package to see if it launches there.

A possible cause is if you are using a File System that we aren’t accustomed to (UFS?).