system server stopped responding - why?

I run the system server (currently 3.11b) on port 5900, but consistently upon trying to connect (locally or remotely) Vine Viewer (3.0) will give me an error that it failed to respond. The availability indicator then stays off.

I am not sure what is going on. I’ve had a number of problems since I migrated my installation from a G5 Power Mac to a 2009 Nehalem Mac Pro. A few tricks that previously got it back up have not solved this now, including restarting, deleting OSXvnc-server settings from firewall and repopulating, trashing my Vine Viewer preferences.

I have tried 3.1b and was on the previous version before that. The system is running the latest everything from Apple. The firewall is on, OSXvnc-server is listed to allow incoming connections. Screen sharing service is off. I can connect to the old machine remotely on a different port so the router shouldn’t be an issue as it is forward to the current LAN IP.

It was just working and then it stopped. The console shows no crash or much else interesting other than:
Mon Jul 27 01:33:00 Athena.local OSXvnc-server[158] : 3891612: (connectAndCheck) Untrusted apps are not allowed to connect to or launch Window Server before login.
Mon Jul 27 01:33:00 Athena.local OSXvnc-server[158] : Window Server is not available.
Mon Jul 27 01:33:00 Athena.local OSXvnc-server[158] : Window Server is not available.
Mon Jul 27 01:33:00 Athena.local OSXvnc-server[158] : CGSCreateEventSourceState: cannot resolve shmem.

I don’t know when it changed, but previously when I opened the Vine Server app, the client server window would say that the server couldn’t start because it may already be running. Now, the client server starts when opened. Using port scan on another machine, 5900 is live only when the client server is started. If I quit the client server and restart the system server, 5900 does not respond.

I am thinking of going back to version 2. Any ideas on what is preventing the system server from operating? What am I missing? Thanks in advance.

So I think I know what the situation is – that error indicates that server isn’t able to run, either because you are at the login window or another user is logged in at the console (primary display). Running a System Server allows you to connect in this way; and was probably what you had running before.

To configure the System Server choose Server->System Server from the main menu, set your connection options and hit start. After the System Server is started you can quit the GUI application.

Thank you, Jonathan.

I followed your directions and it worked, but I don’t understand why and how it didn’t work when I tried before. Questions:
? Why did the system server stop working?
? Why did it not restart when I restarted my computer?
? If I connect (from Vine Viewer) and disconnect more than twice, I get subsequent connection failures:

Connection to Server: server Port:5900 was lost and could not be reestablished.

Why is this happening and how can I reestablish a connection?

BTW, before I get this error, the status shows available. I am prompted for password, but then get the connection error.

I’m not sure if something went awry during the migration or why you had some of the earlier problems.

For now let’s focus on solving whatever remaining issues you have; it sounds like the biggest problem is that after connecting and disconnecting repeatedly you seem to not be able to get in again.

First, is that JUST disconnecting or are you also logging out or doing anything else that might stop the server?

The system server stores a log in /Library/Logs/VineServer.log – you might look at that or post it here as an attachment for clues as to what’s happening.

On this system, I have 1 account, fast user switching is not enabled, I am logging out or putting the machine to sleep. So I am JUST disconnecting the Vine Viewer.

After trying your protocol, I restarted the machine and I was able to connect to the server before the machine was logged in. I was able to connect again after login, but afterward.

Here is /Library/Logs/VineServer.log from last login attempt:

2009-07-30 10:11:21.883 OSXvnc-server[206:521f] Protocol version 3.8
2009-07-30 10:11:21.886 OSXvnc-server[206:521f] Client disconnected
2009-07-30 10:11:21.886 OSXvnc-server[206:521f] Statistics:
2009-07-30 10:11:21.886 OSXvnc-server[206:521f] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:11:25.436 OSXvnc-server[206:5223] Protocol version 3.8
2009-07-30 10:11:25.447 OSXvnc-server[206:5223] -dontdisconnect: Not shared & existing client
2009-07-30 10:11:25.447 OSXvnc-server[206:5223] refusing new client
2009-07-30 10:11:25.448 OSXvnc-server[206:5223] Client disconnected
2009-07-30 10:11:25.448 OSXvnc-server[206:5223] Statistics:
2009-07-30 10:11:25.448 OSXvnc-server[206:5223] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:11:25.575 OSXvnc-server[206:5227] Protocol version 3.8
2009-07-30 10:11:25.583 OSXvnc-server[206:5227] -dontdisconnect: Not shared & existing client
2009-07-30 10:11:25.584 OSXvnc-server[206:5227] refusing new client
2009-07-30 10:11:25.584 OSXvnc-server[206:5227] Client disconnected
2009-07-30 10:11:25.584 OSXvnc-server[206:5227] Statistics:
2009-07-30 10:11:25.585 OSXvnc-server[206:5227] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:11:25.689 OSXvnc-server[206:522b] Protocol version 3.8
2009-07-30 10:11:25.698 OSXvnc-server[206:522b] -dontdisconnect: Not shared & existing client
2009-07-30 10:11:25.699 OSXvnc-server[206:522b] refusing new client
2009-07-30 10:11:25.699 OSXvnc-server[206:522b] Client disconnected
2009-07-30 10:11:25.700 OSXvnc-server[206:522b] Statistics:
2009-07-30 10:11:25.700 OSXvnc-server[206:522b] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:11:37.907 OSXvnc-server[206:522f] Protocol version 3.8
2009-07-30 10:11:37.917 OSXvnc-server[206:522f] -dontdisconnect: Not shared & existing client
2009-07-30 10:11:37.918 OSXvnc-server[206:522f] refusing new client
2009-07-30 10:11:37.918 OSXvnc-server[206:522f] Client disconnected
2009-07-30 10:11:37.919 OSXvnc-server[206:522f] Statistics:
2009-07-30 10:11:37.919 OSXvnc-server[206:522f] framebuffer updates 0, rectangles 0, bytes 0

It looks like the server isn’t letting go of the disconnected client. I checked the server prefs and it was set to allow only one client at a time. It didn’t connect until after I restarted system server.

2009-07-30 10:17:05.813 OSXvnc-server[206:5233] rfbProcessClientProtocolVersion: client gone
2009-07-30 10:17:08.993 OSXvnc-server[206:5237] Protocol version 3.8
2009-07-30 10:17:08.996 OSXvnc-server[206:5237] Client disconnected
2009-07-30 10:17:08.996 OSXvnc-server[206:5237] Statistics:
2009-07-30 10:17:08.997 OSXvnc-server[206:5237] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:17:11.288 OSXvnc-server[206:523b] Protocol version 3.8
2009-07-30 10:17:11.296 OSXvnc-server[206:523b] -dontdisconnect: Not shared & existing client
2009-07-30 10:17:11.296 OSXvnc-server[206:523b] refusing new client
2009-07-30 10:17:11.297 OSXvnc-server[206:523b] Client disconnected
2009-07-30 10:17:11.297 OSXvnc-server[206:523b] Statistics:
2009-07-30 10:17:11.298 OSXvnc-server[206:523b] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:17:11.412 OSXvnc-server[206:523f] Protocol version 3.8
2009-07-30 10:17:11.420 OSXvnc-server[206:523f] -dontdisconnect: Not shared & existing client
2009-07-30 10:17:11.420 OSXvnc-server[206:523f] refusing new client
2009-07-30 10:17:11.420 OSXvnc-server[206:523f] Client disconnected
2009-07-30 10:17:11.421 OSXvnc-server[206:523f] Statistics:
2009-07-30 10:17:11.421 OSXvnc-server[206:523f] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:17:23.627 OSXvnc-server[206:5243] Protocol version 3.8
2009-07-30 10:17:23.637 OSXvnc-server[206:5243] -dontdisconnect: Not shared & existing client
2009-07-30 10:17:23.637 OSXvnc-server[206:5243] refusing new client
2009-07-30 10:17:23.638 OSXvnc-server[206:5243] Client disconnected
2009-07-30 10:17:23.638 OSXvnc-server[206:5243] Statistics:
2009-07-30 10:17:23.639 OSXvnc-server[206:5243] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:17:23.741 OSXvnc-server[206:5247] Protocol version 3.8
2009-07-30 10:17:23.748 OSXvnc-server[206:5247] -dontdisconnect: Not shared & existing client
2009-07-30 10:17:23.749 OSXvnc-server[206:5247] refusing new client
2009-07-30 10:17:23.749 OSXvnc-server[206:5247] Client disconnected
2009-07-30 10:17:23.749 OSXvnc-server[206:5247] Statistics:
2009-07-30 10:17:23.750 OSXvnc-server[206:5247] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:17:50.173 OSXvnc-server[206:20b] OSXvnc-server received signal: 15
2009-07-30 10:17:50.173 OSXvnc-server[206:20b] Unloading Tiger Extensions
2009-07-30 10:17:50.174 OSXvnc-server[206:20b] Unloading Jaguar Extensions
2009-07-30 10:17:50.174 OSXvnc-server[206:20b] Removing Observers
2009-07-30 10:17:50.175 OSXvnc-server[206:20b] RFB Shudown Complete
2009-07-30 10:17:50.400 OSXvnc-server[721:20b] Arguments: -rfbport 5900 -desktop Athena -rfbauth /Library/Application Support/VineServer/.vinevncauth -SystemServer 1 -alwaysshared -allowsleep -restartonuserswitch Y -UnicodeKeyboard 0 -keyboardLoading N -pressModsForKeys N -EventTap 3 -EventSource 2 -swapButtons -rendezvous N
2009-07-30 10:17:50.402 OSXvnc-server[721:20b] Main Bundle: /Library/Application Support/VineServer
2009-07-30 10:17:50.403 OSXvnc-server[721:20b] Loading Bundle /Library/Application Support/VineServer/Resources/TigerBundle.bundle
2009-07-30 10:17:50.419 OSXvnc-server[721:20b] Loading Bundle /Library/Application Support/VineServer/Resources/JaguarBundle.bundle
2009-07-30 10:17:50.423 OSXvnc-server[721:20b] Running in Little Endian
2009-07-30 10:17:50.425 OSXvnc-server[721:20b] Waiting for clients
2009-07-30 10:17:50.425 OSXvnc-server[721:2503] Using Private Event Source,
2009-07-30 10:17:50.427 OSXvnc-server[721:2503] Using Smart Event Tap – HID for console user
2009-07-30 10:17:50.427 OSXvnc-server[721:3807] IPv6: Started Listener Thread on port 5900
2009-07-30 10:17:50.428 OSXvnc-server[721:2503] Started Listener Thread on port 5900
2009-07-30 10:18:02.954 OSXvnc-server[721:3b03] rfbProcessClientProtocolVersion: client gone
2009-07-30 10:18:02.970 OSXvnc-server[721:20b] Waiting for clients
2009-07-30 10:18:07.961 OSXvnc-server[721:510f] Protocol version 3.8
2009-07-30 10:18:07.964 OSXvnc-server[721:510f] Client disconnected
2009-07-30 10:18:07.964 OSXvnc-server[721:20b] Waiting for clients
2009-07-30 10:18:07.964 OSXvnc-server[721:510f] Statistics:
2009-07-30 10:18:07.965 OSXvnc-server[721:510f] framebuffer updates 0, rectangles 0, bytes 0
2009-07-30 10:18:10.434 OSXvnc-server[721:5113] Protocol version 3.8
2009-07-30 10:18:10.446 OSXvnc-server[721:5113] Pixel format for client
2009-07-30 10:18:10.446 OSXvnc-server[721:5113] 8 bpp, depth 8
2009-07-30 10:18:10.447 OSXvnc-server[721:5113] true colour: max r 7 g 7 b 3, shift r 5 g 2 b 0
2009-07-30 10:18:10.447 OSXvnc-server[721:5113] ENCODING: ZlibHextile for client
2009-07-30 10:18:10.447 OSXvnc-server[721:5113] Enabling Rich Pasteboard
2009-07-30 10:18:10.448 OSXvnc-server[721:5113] Enabling Cursor Shape protocol extension for client
2009-07-30 10:18:10.448 OSXvnc-server[721:5113] Enabling Cursor Position protocol extension for client
2009-07-30 10:18:10.448 OSXvnc-server[721:5113] Enabling Dynamic Desktop Sizing for client
2009-07-30 10:18:10.456 OSXvnc-server[721:5113] Client Connected - Registering Screen Update Notification
2009-07-30 10:18:22.017 OSXvnc-server[721:3c0b] rfbSendUpdateBuf: write: Bad file descriptor
2009-07-30 10:18:22.018 OSXvnc-server[721:5113] Client disconnected
2009-07-30 10:18:22.018 OSXvnc-server[721:5113] Statistics:
2009-07-30 10:18:22.018 OSXvnc-server[721:20b] UnRegistering Screen Update Notification - waiting for clients
2009-07-30 10:18:22.019 OSXvnc-server[721:5113] framebuffer updates 26, rectangles 37, bytes 289797
2009-07-30 10:18:22.019 OSXvnc-server[721:5113] ZlibHextile rectangles 35, bytes 289125
2009-07-30 10:18:22.020 OSXvnc-server[721:5113] Cursor Shape Updates rectangles 1, bytes 660
2009-07-30 10:18:22.020 OSXvnc-server[721:5113] Cursor Position Updates rectangles 1, bytes 12
2009-07-30 10:18:22.020 OSXvnc-server[721:5113] raw bytes equivalent 3622555, compression ratio 12.500319

Now it appears to be working again. It looks like the Keep existing viewer option was holding on to the connection. But if my Vine Viewer was the original connection and had exclusive access, why wouldn’t it be allowed to connect again? Same machine, same LAN address, same Viewer… Doesn’t make sense.

Jonathan? Planning to address this further?

Am I not understanding how this is supposed to operate?