Spotlight Oddity

While connecting to my MacBook (running Vine Server 3 as a system service under Leopard) from my Windows machine at work, I am running into an odd problem.

When I click the Spotlight magnifying glass (or hit Command + Spacebar) and begin typing in the Spotlight search box, Mac OS responds as if I have the Command key held down. For example, I cannot type an “r” or an “i” (nothing shows up in the search box). If I begin to type “Word”, I get through “Wo” (and Microsoft Word is now selected as the Top Hit) and then I type “r” and MS Word is now “revealed” in the finder as if I had typed Command + R.

This same problem occurs for the letter “i” (and presumably any other Command+key combination).

The only thing that resolves the problem is restarting the Vine Server. Oddly, this behavior doesn’t seem to start happening until the Vine Server has been running for a while.

I’ve tried all of the following to resolve the problem, which did NOT work:

  • Reconnecting the VNC client
  • Using a different VNC client (tried TightVNC, UltraVNC and RealVNC)
  • Changing the keyboard settings within Vine Server
  • Tapping the Command (Alt in Windows) key in case the VNC client though the key might be pressed

Has anyone else experienced this problem or know why it might be happening?


I’ve had the exact same issue connecting to leopard server on a G4 cube from Linux realvnc.

My experience is the same as yours and the problem only arises sometimes… I have apple remote desktop installed also…

We are looking carefully into this problem.

For the moment we seem to be able to avoid this from occurring by adding

-EventSource 3

To the “Command Line Arguments” in Preferences -> Advanced

So far I have not experienced this problem while using the “-EventSource 3” parameter. I’ll report back if I ever do.

Thanks, Jonathan!

I encountered the same problem running Vine Server 3.0 on Leopard 10.5.2
from any of the various VNC clients on Windows XP.

I reverted back to Vine Server 2.1 and this seems to work better.

Did you try the -EventSource 3 workaround?

Hello! I went back and reinstalled Vine Server 3.0 (1016) and tested with the -EventSource 3 switch in the Advanced preferences.

I confirmed that using the -EventSource 3 switch alleviates the Spotlight keyboard problem.

I’m sorry I did not try this earlier. Thanks!