[SOLVED] vine server & mac os x panther

hi i’m trying to install a vnc server on a power mac g4 with panther 10.3.9. I get
an error when i start manually the server form the main interface. I press the “start server” key and i get the message: “the server has stopped. Watch report (5).” I don’t know what this report 5 thing is. I’ve forwarded correctly the port 5900 to the computer.
can someone please help me?


What version of Vine Server are you running – can you post the log?

sure! I’ installed the latest version, v3.0 (v1016). Those are the log files produced just by opening the program:

2008-01-07 12:07:31 +0100 Starting Vine Server 3.0(1016)
-rfbport 0 -desktop Computer-di-admin (admin) -rfbauth /Users/admin/.vinevncauth -nevershared -dontdisconnect -restartonuserswitch N -UnicodeKeyboard 0 -keyboardLoading N -pressModsForKeys N -EventTap 3 -swapButtons -rendezvous Y

2008-01-07 12:07:32.080 OSXvnc-server[444] Arguments: -rfbport 0 -desktop Computer-di-admin (admin) -rfbauth /Users/admin/.vinevncauth -nevershared -dontdisconnect -restartonuserswitch N -UnicodeKeyboard 0 -keyboardLoading N -pressModsForKeys N -EventTap 3 -swapButtons -rendezvous Y
2008-01-07 12:07:32.117 OSXvnc-server[444] Main Bundle: /Applications/Vine Server.app/Contents/Resources
2008-01-07 12:07:32.119 OSXvnc-server[444] Loading Bundle /Applications/Vine Server.app/Contents/Resources/TigerBundle.bundle
2008-01-07 12:07:32.123 OSXvnc-server[444] Loading Bundle /Applications/Vine Server.app/Contents/Resources/JaguarBundle.bundle
2008-01-07 12:07:32.139 OSXvnc-server[444] Running in Big Endian
2008-01-07 12:07:32.165 OSXvnc-server[444] Waiting for clients
2008-01-07 12:07:32.166 OSXvnc-server[444] Using Private Event Source
dyld: /Applications/Vine Server.app/Contents/Resources/OSXvnc-server Undefined symbols:
/Applications/Vine Server.app/Contents/Resources/TigerBundle.bundle/Contents/MacOS/TigerBundle undefined reference to _CGEventSourceCreate expected to be defined in ApplicationServices

and this is console.log

Mac OS X Versione 10.3.9 (Build 7W98)
2008-01-07 12:07:19 +0100
2008-01-07 12:07:30.701 Vine Server[428] Loading Bundle /Applications/Vine Server.app/Contents/Resources/TigerBundle.bundle

2008-01-07 12:07:30.728 Vine Server[428] Loading Bundle /Applications/Vine Server.app/Contents/Resources/JaguarBundle.bundle

2008-01-07 12:07:31.338 Vine Server[428] CFLog (0):

CFPropertyListCreateFromXMLData(): plist parse failed; the data is not proper UTF-8. The file name for this data could be:

/Applications/Vine Server.app/Contents/Resources/Italian.lproj/Localizable.strings

The parser will retry as in 10.2, but the problem should be corrected in the plist.

By reading them i suppose panther is not suitable for the latest version…where can i download an older one?
Thank you so much


Some of the newer features are Tiger only and have been encapsulated in the Tiger.bundle. That bundle is supposed to just not load on 10.3. Try removing the Tiger.bundle package found inside the Vine Server.app/Contents/Resources folder.

We’ll be fixing that issue shortly.

great! i haven’t tried any connection, though that bug is corrected. thank you so much!!


Where can I find this file to remove it or disable it? I have performed many searches and can’t find the tiger.bundle file to remove it.

Control-Click on Vine Server.app in the Finder and select “Show Package Contents”. You will get a new Finder window showing what’s inside the application wrapper.

Find the Contents->Resources->Tiger.bundle and drag it into the trash (you may need to authenticate).

Now I’m not confused anymore. Thanks for your help. If you get a message that I was trying to contact you. You can disregard.