Should the System Server give me control of the Login Window

Isn’t the System Server supposed to work from the machine’s Boot Up onward? If so, that would include giving a Vine Viewer (or other VNCclient) screen access at the login window, right?

Well, I installed the system server on a remote machine while connected to it via the Vine Viewer and Server Combo (I like!). I verified that it worked as I was able to reconnect the Viewer to the system server, quit the desktop server, quit the Vine and still maintain control of the screen.

Then I went ahead and logged the user out via the apple menu (BTW cmd-shift-q didn’t work). Then I completely lost control of the machine via Vine Viewer. WHY??!? i was so sad.

luckily i found a ssh command to help me reboot the machine! I know nothing of terminal or ssh, so I’m scared I may have screwed something up. I think I’m good though.

Again, my question is
Isn’t the System Server supposed to work at the login window, right?

I posted this question in a loquacious response to another post.

Yes, that is exactly what the system server is supposed to provide. It’s possible that in some configurations logging out (with-out first restarting) could prevent access to the Log-In window.

So that we can track your scenario down more precisely -

What version of Vine Server was it?
What version of Mac OS X was it?

Vine Server & Vine Viewer 3.0, installed yesterday (sweeeeeeet)

10.4.11 on both client and server.
Client is intel Macbook 2.16 GHz core 2 duo.
Server is PowerMac 2.5 GHz G5 Quad Core.
Connecting with VNC password to system server on defualt ports @ 256 colors. Learning to connect via ssh as we speak, total noob.

Oh! Well, yes I had not restarted the remote machine yet. DUH!!! That’d do it, wouldn’t it!?!

Let’s see if it works now. . .
. . . on another note pressing cmd-shift-q in full screen mode) after clicking in the window) only tells my local machine to logout, not the remote machine. this is in contradiction to the help file:

Full screen control allows you to bypass your local system and send key commands to
the remote computer (except for Command-Option-Escape, which quits your application

. . . logging out via the apple menu works
. . . yup! it works! Yay!

i can’t believe i forgot to reboot!

thank you!

I found this very same thing. I connect remotely to my machine, but had lost connection with the good ol’ “WriteExact” error. So, I used Remote Buddy on my iPhone to reboot the Mac remotely. When it came back up to the login screen, I couldn’t connect (kept timing out). I waited about a half hour of trying before calling my wife to log me in!

Am I missing something here? Is there something I can check to ENSURE the system server starts up during a reboot?

I am using Leopard 10.5.1

Thanks for a great app!

I’m using the service. It seems the server IS starting during boot. I tested it by using my actual IP address to connect via SSH with Putty. No problem there.

I’m wondering why the updater is not working at bootup.

Willyeam, is this how you’re connecting to your machine (using a DNS Service)? Or are you connecting directly to the IP address?

With Mac OS X 10.5.2, I am finally able to connect to my iMac
wirelessly after a reboot. Then all I have to do is set up the right
SSH port forwarding and the System Server allows me to
access the Log In screen just fine. After I log in, the VNC connection
is reset, and I have to reconnect in order to access the regular
user screen, but that’s a minor annoyance.

For some reason it seems quicker over the WAN link than before.
Maybe that’s the Leopard Graphics Update.

Hi - I’m an Eggplant/Vine newbie.

I’m using two 10.5.2 Macs and have been successfully writing a bunch of test scripts in Eggplant Green (running in demo mode), but I’ve run into problems writing tests scripts that involve a logout/login. The problem is that although I can log out, and I have control over the login screen, as soon as I enter the login name and password for my SUT account and hit login, I lose control of the remote Mac.

I should be able to logout and log back in to the SUT without losing my connection, correct?

I have both system and desktop servers running on my SUT, and have connections to both on the machine where I’m running eggplant. The desktop server connection is lost on logout, as expected, but I’m having this problem with the system server connection getting lost on logIN.

I’m not sure what info/prefs might be relevant here …

  • Authentication is set to None for both system and desktop servers
  • desktop and system servers are running on different ports
  • for system server startup prefs, ‘start server when vine server application is launched’ and ‘restart server if it stops unexpectedly’ are both checked.

I’m logging out of the SUT and entering my login info using an eggplant script (via the Apple menu > logout), but the same thing happens if I logout at the SUT itself.

Any help would be greatly appreciated.

This may be difficult to do in Eggplant Green (now known as SE: Starter Edition), since it lacks the ability to issue a “connect” command to reconnect to the server following the login. The problem is complicated by the way the servers work on Leopard (10.5) because you can’t stay connected to a single server across logging out and in again.

You may want to try this under Tiger (10.4) instead, if that is possible for you, or get a trial license for Eggplant Purple (now known as Eggplant FT: Functional Tester) to see how that works for you.

Yes, the problem is that on 10.5 there is a separate Vine Server running for the login window which is then shutdown when a user logs in. (On 10.4 the same server stayed alive during the login process).

When the VNC connection closes, Eggplant will attempt to reconnect but only for a fixed number of trials. As Doug pointed out Green does NOT have the ability to initiate a connection from a script. In response to your inquiry we have added the ability to extend the reconnection attempt.

So it sounds like the problem is that your account isn’t logging in and having the Vine server restart in time. You might be able to get this to work by modifying the Vine Server launchd configuration and then restarting the machine. This file is at /Library/LaunchAgents/com.redstonesoftware.VineServer.plist

Here is the code to add right near the end before :

	<key> ThrottleInterval </key>

[quote=“JonathanOSX”]You might be able to get this to work by modifying the Vine Server launchd configuration and then restarting the machine. This file is at /Library/LaunchAgents/com.redstonesoftware.VineServer.plist

Here is the code to add right near the end before :

	<key> ThrottleInterval </key>


No joy. The frustrating thing is that I was able to maintain a connection through login ONE time, out of the 30+ times I’ve tried.


I experienced a similar problem to that described in the original post and for too long a time (until I found that) I was trying all sorts of options - not least stopping and starting the System Server via the options on the System Server window. It is not clear from the documentation that a re-boot is necessary and this requirement has me wondering what purpose is of the “Start System Server” option on the System Server window. The documentation says, quite obviously it seems, “When you click the Start System Server button, the system server starts running.” - but that appears not always to be the case. As well as clarification in the manual the note on that window could be improved.