segmentation fault

I’m always getting this error with osxnvc, no matter what client or compression I use. After getting this error once (and the server crashing), it works again (I can restart the server and then connect). Is this a bug?

I should mention that I start osxvnc-server in /Contents/MacOS/ directly via the console. Is this not the intended way? Anyway, I use Mac OS X 10.2.8.
(If it’s not the intended way: how DO I start osxvnc via the console?)

[EDIT] the small letter “oh” (“o”) doesn’t work, either. [/EDIT]

Any help would be greatly appreciated!


It’s ok to launch the server in console mode, you might try launching using the link that is provided directly inside the app wrapper, this prevents a Dock item from trying to show up in the dock (which may be the cause of the crash):

Outside of that we don’t have anything to suggest. We aren’t seeing this bug here at Redstone although we have heard reports of it in the field anything more you can tell us about the bug will help us to track it down.

Well I can show you the errors:

[EDIT] Your advice changed nothing, unfortunately. [/EDIT]

2005-01-13 23:11:13.857 OSXvnc-server[578] Main Bundle: /Applications/
2005-01-13 23:11:13.874 OSXvnc-server[578] Loading Bundle /Applications/
2005-01-13 23:11:13.940 OSXvnc-server[578] Keyboard Loading - Enabled
2005-01-13 23:11:13.941 OSXvnc-server[578] Press Modifiers For Keys - Enabled
2005-01-13 23:11:15.444 OSXvnc-server[578] Keyboard Detected: Swiss German (Type:1) - Loading Keys
2005-01-13 23:11:15.445 OSXvnc-server[578] Loading Keys For Modifer State:0000
2005-01-13 23:11:15.455 OSXvnc-server[578] Unable To Convert KeyCode, Multiple Characters (0x5e) (0x39) For: 25 (0000)
2005-01-13 23:11:15.456 OSXvnc-server[578] Loaded 67 Keys
2005-01-13 23:11:15.456 OSXvnc-server[578] Loading Keys For Modifer State:0x02
2005-01-13 23:11:15.456 OSXvnc-server[578] Unable To Convert KeyCode, Multiple Characters (0x60) (0x29) For: 25 (0x02)
2005-01-13 23:11:15.456 OSXvnc-server[578] Loaded 42 Keys
2005-01-13 23:11:15.457 OSXvnc-server[578] Loading Keys For Modifer State:0x08
2005-01-13 23:11:15.457 OSXvnc-server[578] Unable To Convert KeyCode, Multiple Characters (0xab) (0x7d) For: 25 (0x08)
2005-01-13 23:11:15.457 OSXvnc-server[578] Unable To Convert KeyCode, Multiple Characters (0x7e) (0xb5) For: 46 (0x08)
2005-01-13 23:11:15.457 OSXvnc-server[578] Loaded 43 Keys
2005-01-13 23:11:15.457 OSXvnc-server[578] Loading Keys For Modifer State:0x10
2005-01-13 23:11:15.457 OSXvnc-server[578] Loaded 17 Keys
2005-01-13 23:11:15.458 OSXvnc-server[578] Loading Keys For Modifer State:0x0a
2005-01-13 23:11:15.458 OSXvnc-server[578] Loaded 43 Keys
2005-01-13 23:11:15.459 OSXvnc-server[578] Loading 56 XKeysym Special Keys
2005-01-13 23:11:16.303 OSXvnc-server[578] Waiting for clients
2005-01-13 23:11:16.304 OSXvnc-server[578] Started Listener Thread on port 5900
2005-01-13 23:11:16.344 OSXvnc-server[578] Registering Rendezvous Service - iMac.local.
2005-01-13 23:11:42.340 OSXvnc-server[578] Protocol version 3.5
2005-01-13 23:11:42.340 OSXvnc-server[578] Ignoring minor version mismatch
2005-01-13 23:11:42.356 OSXvnc-server[578] Pixel format for client
2005-01-13 23:11:42.357 OSXvnc-server[578]   32 bpp, depth 24, little endian
2005-01-13 23:11:42.357 OSXvnc-server[578]   true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
2005-01-13 23:11:42.361 OSXvnc-server[578] Using CoRRE encoding for client
2005-01-13 23:11:42.361 OSXvnc-server[578] Enabling Cursor Shape protocol extension for client
2005-01-13 23:11:42.361 OSXvnc-server[578] Enabling Cursor Position protocol extension for client
2005-01-13 23:11:42.362 OSXvnc-server[578] Using image quality level 6 for client
2005-01-13 23:11:42.362 OSXvnc-server[578] Enabling LastRect protocol extension for client
2005-01-13 23:11:42.362 OSXvnc-server[578] Enabling Dynamic Desktop Sizing for client
2005-01-13 23:11:45.312 OSXvnc-server[578] Client Connected - Registering Screen Update Notification
Segmentation fault

and after I start it up again, it works, as I said. The error concerning the “o” (oh) character, which does not provoke an error, reads as follows:

2005-01-13 23:15:01.088 OSXvnc-server[582] Warning: Unable to determine Key Code for X Key Sym 111 (0x6f)

All other keys seem to work, also the Big-Oh.

Maybe the problem is that the screen goes to sleep? I dont know.

The aqua app doesnt work either. Really nasty , please fix it ASAP.

What system are you connecting from? Are you using US keyboard settings on both ends?

Both the Aqua app and the startup item work great for most people (thousands of them, actually) – we get compliments on the package every day. When you say it “doesn’t work”, are you referring to the same problem as above?

We have worked dilligently to try to recreate this problem but we can not get it to happen on 10.2.8 or 10.3.7.

Since you are the only person reporting this behavior and you are seeing it in the GUI app and the command line app it’s likely that something on your system is interfering with OSXvnc’s ability to function.

First question, are you running any tools using APE from Second are you running any other third party utilites that would effect the system or other applications across the board?

If you have either an or an OSXvnc-server.log in your ~/Library/Logs/CrashReporter directory please send those to us.

If you have access to another MacOS X system it would be helpful for you to try OSXvnc there also.

Unfortunately, files cannot be attached in this forum, so I’ll just mail them to you ( Anyways, I’m very grateful to you that you took your time to look into this. Probably it’s because of the Windows client I use (standalone version of TightVNC):

frome the readme file:

TightVNC 1.2.9 Binary Distribution for Windows platforms

This distribution is based on the standard VNC source with
modifications introduced in TridiaVNC 1.4.0, and includes new
TightVNC-specific features and fixes, such as additional low-bandwidth
optimizations (“Tight” encoding with optional JPEG compression, “local
cursor” feature), improved WinVNC advanced settings, and much more.

Executable files included in the release:

Complete TightVNC server: winvnc.exe, VNCHooks.dll
TightVNC Viewer: vncviewer.exe

TightVNC is available under the terms of the GNU General Public
License (GPL), inclided in the file LICENCE.txt. You can freely use
the software for any legal purpose, but we’re asking for a donation to
the TightVNC project from commercial users, as well as from motivated
individuals, who like the software. You can donate any amount of your
choice starting at 10 U.S. dollars. See the details here:

Your support ensures we can add more new features and fix more bugs,
making TightVNC a better software for you. Thank you in advance!

I downloaded the latest version. (and yes I tried ot several compression methods)

I would be glad to hear of a better client for Windows, if that would solve the issue.

BTW I used VNCDimension or another mac client as well, with the same crashes.

We’ve looked at your crash logs and it really appears that something is wrong with your system installation. This will no doubt sound like we are trying to pass the buck, but OSXvnc isn’t doing anything at the time of the crash except running the event loop – all of the activity is from Apple’s system calls and they have nothing to do with OSXvnc. This is not an issue that is being reported by other users, which further points to a problem on your machine. Unfortunately, the best suggestion that we can offer based on the available information is to reinstall Mac OS X.

You might also try rebooting your machine while holding down the shift key; this is the “Safe Boot mode” and will disable startup items and nonessential kernel extensions. Hold the shift key down during login to disable any login items. If the VNC server then works, then there is some conflict with something else that is normally being loaded.


Yes, that is possible, I was expecting such an answer a bit actually after I had read your posts. Maybe I’ll install Panther onto it, but that’ll have to wait, I don’t have the time for that right now.

I have what seem sto be a similar error. I run the OSXvnc server, connect a client which causes a crash of the server app, then when I restart the server the client connects. The error is either a segmentation fault or a bus error.

I’m using OSX 10.2.8 on a TiBook for the server, and my client is WinXP on a Thinkpad. I’m usually connecting via an SSH tunnel.

I run /Applications/OSXvnc/OSXvnc-server to start it, as recommended above.

I checked for APE yesterday, and it is installed on my system. I added OSXvnc to the exclude list, although I didn’t actually reinstall OSXvnc. I’m thinking that maybe there are OSXvnc prefs that should be removed?

I use two different clients to connect: the realvnc windows VNC viewer, and TightVNC viewer.


edit: My workaround for this is to wrap the VNC server startup in a shell script which executes the startup twice in a row. Thus, when the first OSXvnc process crashes, the second one starts right away, and then my client can connect.

Hello again!

I fixed my troubles (for now) with a system upgrade to Panther. Possible that my installation was corrupted :stuck_out_tongue:

That’s good news. Thanks for the update!