Scrolling not working after upgrade to Lion (Mac OS 10.7)

Just upgraded to Lion. When I connect using Vine Viewer, when I attempt to scroll a remote window in the viewer it does not work. Instead, the entire server desktop scrolls within the Vine Viewer window on my local desktop.

What do I have to do to restore the ability to scroll a remote window?


What server are you connecting to? Is it the Vine 4 beta server or is it the built-in screen-sharing server? If it’s the screen-sharing server, it’s probably just one of the ways that their implementation is broken.

It is the vnc server that is installed on the Linux host I am connecting to - its a Red Hat distribution:

[bidsjagu@yyc-jg-x3500 trunk]$ uname -a
Linux yyc-jg-x3500 2.6.18-194.17.1.el5 #1 SMP Wed Sep 29 12:50:31 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

Why did this work ok before I upgraded to Lion?


It may be because the nature of scrolling has changed under Lion. Note that scrolling under Lion moves in the reverse direction of what it did under previous versions of the OS. I’m not sure if that’s changing the events that Vine Viewer is sending, but it’s one possibility. Vine Viewer itself hasn’t changed and there is that obvious change to the system behavior.

Ok. Fair enough. But for me scrolling is broken, and I need to scroll. What can be done to get this working?


Aren’t there scrollbars that you can click on or drag? This is the first report we’ve had of this issue. If we reproduce it, we’ll try to fix it for a future release. If it becomes a big problem for our user community or impacts our eggPlant testing product, then it will get fixed sooner, but I would still expect it to be quite some time before a new version of Vine Viewer is released.

Yup clicking on scroll bars works still, so this is not a disaster. Still, I am very used to being able to scroll just by touching the window I want to scroll. I guess I will see if I get any joy from any of the other Mac supported VNC clients. Thanks for your quick replies!

Jay – just to be sure, have you tried making sure that your preference is set correctly?

Be sure that Vine Preferences->Viewer Window->Mouse Scroll Wheel is set to Remote Window. (The default behavior is to do local window but it would NOT do that if the window was already full screen, not sure if this is what’s changed for you or not).

As pointed out the default scrolling behavior on Lion is inverted, so you’ll probably want to make change that in Lion System Preferences as well.