Reverse VNC (VNC SC) connection failure after upgrade

I upgraded my Vine Viewer to version 3.0 and since I did, reverse VNC connection attempts fail. With the previous version, 1.2, it was working perfectly well.

When I run the VNC SC executable on the client pc, to connect to my viewer and in that way get trough firewalls and NAT routers, I can see the connection attempt in the Connection List, first as:

Status: green/orange
Name: Client IP
Host: Client IP
Port: 5500
Color: Default
Activity: Trying to connect - Client IP: 5500

and a little while later as:

Status: red
Name: Client IP
Host: Client IP
Port: 5500
Color: Default
Activity: Connection failed:Operation timed out

It seems that, since version 3.0, Vine Viewer tries to connect back to to client, after the client already tried to set up a connection or something?! That fails of course, because in that way the firewall/NAT router is a problem after all.

I have tested on a remote host (on same LAN via gigabit) a OS X 10.4.10 Vine Server requesting a reverse connection to Vine Viewer port 5500 (default) without problems. Please specify your VNC Server OS version so we can try to emulate your configured environment with the problem.

It doesn’t surprise me that you’re not facing problems that way. In your case, the IP received by the host leads directly to the client which requested the connection. If there’s no firewall, there’s no problem for the host, in connecting to the client. However, if the connection is requested over the Internet, the IP received by the host is the external IP which doesn’t directly lead to the client pc. Any “answering” connection attempts by the host end up in a router then. My testing environment consists of an OS X Leopard host and a Windows XP client, for as far that still matters.

I do have exactly the same problem as ‘tvdien’ with Reverse Connections on my iMac Core Duo 2.0 GHz with 10.5.1.

It works with Vine Viewer version 1.2 but not with 3.0.
The other side uses UltraVNC SingleClick (without DSM encryption) on a PC / or Vine Server on a Mac:

I’m curious if my problem has been verified by now. So far, upgrading to version 3.0 brought me nothing but cost and trouble. :expressionless:

… :x

I had trial version, 2.X and the trial ran out. So I got out my Master Card and upgraded to 3. I can connect from my Macbook pro 10.4 to my G5 10.4 when they are in the same room and same T1 line. but I come home with the Macbook pro and phone DSL and cannot connect – get the yellow green ball then it goes to red. No luck here and it used to work. Could go back and use old model, not sure if license number will work but worth trying.

Any advise would be appreciated.

I actually already owned version 1, and upgraded for no reason besides supporting the developers. I’m really disappointed we haven’t received an answer on this yet.

Note that I can rule out all other factors besides Vine. I’ve been using the same UltraVNC SC executable for over a year, and it still works fine with RealVNC in addition to version 1. To recap the problem, the connection line appears on the connection list with an orange circle indicator, becomes about 1/8th green, and then it turns red with the error “Connection failed: Operation timed out” a few seconds later.

I don’t use the reverse connection very often, but it’s the primary reason I purchased Vine Viewer. I’m having the same problem everybody else in this thread has described, but I could have sworn that it used to work in 3.0. I’m not 100% certain, but I believe that 3.0 is the only version that I’ve had.

Perhaps it’s an OS update combined with 3.0 that’s causing the problem. I’m running 10.5.2 right now, but don’t have another machine to test with.

I’m running UltraVNC SC on the remote machine, and can confirm that the same UltraVNC SC executable can connect to a WinVNC client in listen mode through my firewall on my network, but my Mac running Vine Viewer 3.0 just gets the 1/8 green, 7/8 yellow indicator, and a message on the console saying:

3/29/08 6:26:50 PM Vine Viewer[8463] Error when establishing reverse connection: Unable to connect to Server:x.x.x.x on port:5500
Connection failed:Operation timed out where x.x.x.x is the IP of the remote computer running UltraVNC SC.

Is there any progress with this issue?

Ok – first off let me apologize to ANYONE encountering this problem. We greatly encourage use of the forums and this thread slipped through our support process.

Let me thank those of you who HAVE purchased Vine (either version 1 or version 3); it is much appreciated and your concerns here should have been addressed much sooner.

Let me see if I can get at a minimum a workaround and hopefully a Beta version of Vine that addresses this problem.

For anyone needing to download the older version please use:


Thanks for the link to set up the older version of VNC viewer while you come up with a beta fix for us who cannot use version 3. But lo and behold, I cannot enter my license code and when I try to use as a trial, it says a newer version is available and would I like to buy. I already have it and cannot connect. This is very exasperating. Wish I never bought this software! please advise. :cry:

Please send an email to support with your email address and we’ll get you (or anyone else in this predicament) a V 1 key.

For people experiencing this problem, please try the following corrective workaround and let us know if it improves the behavior for you:
Launch Terminal and enter the following command:

defaults write com.redstonesoftware.Vine DisabledEncodings -array-add DesktopSize

Then relaunch Vine and try your reverse connection.

I have the same problem. The disable thing

defaults write com.redstonesoftware.Vine DisabledEncodings -array-add DesktopSize

Does not work for me too. We have the following versions:

OSX: 10.5.3
Vine Viewer: 3.0 (1030)

Will request an old key now :cry:


There shouldn’t be any problems doing a reverse connection vine-to-vine. If you are experiencing a problem here then it’s likely a network issue.

Have there been any updates on this issue?

I just purchased for 3.0, but have encountered the same issues. I’ve already requested a 1.2 key, but I was curious if there had been any updates.

I tried the terminal command suggested, but found no change.


I have the same problem.

This seem to be UltraVNC SC specific.

That is, Vine Viewer on Mac OS X must be used with listening enabled. Then starting UltraVNC SC on a Windows machine that connects to this mac will have this problem.

Suprisingly the same connect command to set up the server initiated connection with vanilla UltraVNC works for me. Server initiated connections also work when using TightVNC.

So the problem might be with UltraVNC SC, not Vine Viewer.

The same problem with reverse connections with UltraVNC SC still exists with the Beta 3.1 version of Vine viewer.

And version 1.2 doesn’t work on Snow Leopard anymore :-(.