Remote Desktop not receiving "Windows Key" command

I have read through all of the related posts and have found similar situations, but none of the solutions have worked so far, so here’s my problem:

I am currently working on a script to automate the process of dialing into our remote servers and change the administrator passwords. We have two connection types, Remote Desktop and Citrix.

The SUT is a 2003 Server and has absolutely no problem receiving the “Windows Key” commands to open the start menu (\w, \W, windowsDown, and windowsUp) on the SUT itself.

If I log into a 2003 server from the SUT using Remote Desktop, the “Windows Key” commands will not open the start menu on the remote machine. After looking on Google, I found an alternate hotkey combo to open the start menu in a Remote Desktop session (ALT+HOME) but this will not work either. If I am on my Windows XP laptop and log into the same server with Remote Desktop, the “Windows Key” on my keyboard opens the start menu on the remote machine with no problem, but no matter what I try, I cannot open the remote start menu with any key combinations from the SUT. Has anyone experienced this, and if so, is there a work around?


Try control + escape:

TypeText “\c\e\C”

That worked beautifully! One more question, though, if you are still feeling generous…

Is it possible to use this key combination to launch the “Run…” dialog? In windows it’s “Window Key+r”, but Ican’t seem to get it to work with the “control+escape” combo. Even if it can’t be done, thanks for the help in advance!

I tried the same key sequence as well as others and could not get it to work. I have reason to believe that the Windows key does not get interpreted correctly when you attempt to piggyback VNC with a Windows Remote Desktop session.

However, once you have the start menu open you can use the image capture technique to click on the Run item. All you need to do then, is to capture an image of the Run item located under your start menu.

If you are really desperate to get the key combo to work I suppose you can attempt to remap your Windows key. This however, involves modifying the Windows’ Registry. Do at your own risk. Here is the article:

There are also other utilities available that will allow you to remap keystroke shortcuts without modifying the registry.

Hope that helps!

Thanks for all of the help! I just went ahead and made the images, but ended up having to set a click position for the remote Citrix start menu because I am using the “2000 look” on my XP machine, so all of the start buttons look the same, but the script ran through beautifully on the first try. Thanks agaion for everything!