Recent Mac OS X update killed my VNC Server?

I’m not entirely sure if Apple’s updates are responsible but I’ve not done anything else with my Mac since updating. I ran Vine Server 24/7 for the last few months and it’s worked without issue until I ran a “Software Update” the other day.

I try to start the server manually by pressing the start button at the bottom of the application window but it errors out and refers me to the logs…

Starting Vine Server Version 2.1
-rfbport 0 -desktop Mn -nevershared -nodimming -disableScreenSaver -protocol 3.3 -restartonuserswitch N -keyboardLoading N -pressModsForKeys N -swapButtons -disableRichClipboards -rendezvous N -rfbauth /Applications/Vine

dyld: Library not loaded: /usr/lib/libz.1.1.3.dylib
  Referenced from: /Applications/Vine
  Reason: image not found

Seems like the .dylib file in question is 404 so should I just get another copy of the file and try it?

I have been reading more about 10.4.9 and other developers having problems with missing files and also incompatabilities. We of course have put out an advisory to avoid 10.4.9 while using our products, as can be seen in the Eggplant Forums. However in your case with Vine Server, if a file is 404, then grab another copy of the Vine Server application and do a install replacement to see if that solves the problem. Please recall, Vine Server is free and given away as a courtesy to the OSX world from Redstone Software, whereas Vine Viewer is a product we gladly sell and fully support here in the VNC Vine Viewer Forums.

Thanks for the response Todd.

I actually connect to the VNC Server on my Mac from my PC with UltraVNC’s viewer… which incidentally is also free ( )

Anyway, the VNC Server I was running was your older 2.0 version. I removed that and then installed the latest 2.1 but it still brings up the same error :frowning:

Is the libz.1.1.3.dylib file in question a system file that’s part of Mac OS X or does it get installed by your VNC Server app?

Please check for the file


and also its permissions. It is a system lib provided by Apple in OS X.


Well, I found the file and it’s a symbolic link to another file and folder that I can’t even find…

lrwxr-xr-x    1 root  wheel       12 Feb  5  2006 libz.1.1.3.dylib -> .so man3/mib

…so I guess that’s why VNC Server complains it can’t find it :frowning:

As of the 10.4.x releases, I believe all libz files will point (linked) to the libz.1 and 1.2.3 builds. Your situation looks to be that some install (maybe apple update) trashed that link. I’m sorry to hear this, and yes that is why the application won’t run. Reinstall OS X and try again, or just install and fix the libz.