reach a system behind two routers

Hi I am trying to setup VNC Server on an OSX Snow Leopard system and I want to connect to it with VNC Viewer from a remote location. This system is behind two routers. The top level is 192.168.1.xx network and the second level router is 192.168.2.xx network. The second router shows up on the first as and the system I want to connect to is on the first router have forwarded the ports 5900-5909 to which I am assuming directs all vnc traffic to the second router. Then on the second router I forward those ports to which is the system I am trying to reach. After all of this I still cannot connect to the system. Is there something I am missing? Any suggestions?

It sounds like you’ve done everything correctly so I’m not sure what the problem is unless the local machine is running a firewall.

Sometimes it’s helpful to try hitting it from an external web browser using the syntax IP:port and see if you get the RFB handshake.

I checked the firewall settings on the local machine. No luck. I tried both on and off and when it was on I explicitly allowed connections for Vine Server. On the local network I can get the RFB handshake through the web browser but I still cannot through an external connection.

Another note is I tried connecting the system to the top level router just to try to see if it would work but I still cannot get external connection. This tells me that it is something beyond having two routers. Even with ports open and DMZ enabled still something is blocking!