RDP to Win10 and launch Citrix app - support encryption

I am using eggplant functional. I connect to a Windows 10 machine through RDP. I launch an application hosted on Citrix. The application returns “This version of Citrix Receiver does not support selected encryption. Please contact your administrator.” If I use remote desktop from the machine hosting eggplant functional to connect to the same machine with the problem, then I can launch the Citrix application. Is there anything that can be set to change the encryption?
I have tried reloading the citrix receiver on the problem box but still get the same error. I don’t have access to repair the citrix receiver.

Thank you.

There are a number of settings related to the RDP connections that you can change via the command line. One or more of those may help with this issue (and if they don’t, there isn’t really anything else that can be changed). The settings are:

(ALL default to YES (enabled)) if not modified, with the exception of rdpExtSecurity:

• rdpRdpSecurity NO - disabled RDP security authentication
• rdpTlsSecurity NO - disables TLS security authentication
• rdpNlaSecurity NO - disables NLA security authentication
• rdpExtSecurity YES - enables extended security authentication (off by default)
• rdpIgnoreCertificate NO - DO NOT ignore certification - DEFAULT = YES = IGNORE CERTIFICATES
• rdpAuthentication NO - disables authentication
• rdpNegotiateSecurity NO - do not do security negotiation

To use these settings, you need to quit eggPlant Functional. Then open a cmd prompt and chdir to the eggPlant install directory. Change the settings using commands like this (case sensitive):

defaults write Eggplant rdpRdpSecurity NO

Then launch eggPlant and try your connection. To restore the default, you can just delete the setting:

defaults delete Eggplant rdpRdpSecurity

I would try each of these in turn and check the result. I suspect that it may be just one of these settings that is causing the problem with your Citrix connection, but I cannot say for sure. We do not have access to a Citrix system to test against.

Let us know if you have any other questions.