Problem facing with Eggplant 3.0 with iMac machine.

Hi All,

I have downloaded Eggplant new version 3.0 on my Mac machines- Power Mac G5 and iMac.

The downloaded dmg working perfectly fine with Power Mac G5 but not on iMac, while connecting to remote Intel desktop. I’m using RealVNC 4.0 version for connecting to remote desktop.

What can be the problem with iMac :?: Is there any setting we need to do for it???

Eggplant should work just the same on the G5 and on the iMac. Can you give more details about the problem you’re having? Is any error message displayed when you try to connect?

Everytime i try to connect to remote Windows desktop it give the status as “Connect to server failed: Connection operation timed out” while establishing connection. :cry:

But connection working perfectly fine with the previous version of Eggplant 2.22. Also, the connection to remote Mac works perfectly with the Eggplant current version 3.0. Only facing problem with remote Windows desktop. :frowning:

Are you also able to connect to the remote Windows Desktop from your G5 running EP 3.0?

Yes i’m able to connect to the remote Windows Desktop from G5 using EP 3.0 version. But still facing problem with iMac. :cry:

I followed all the VNC settings as mentioned in “Using Eggplant” manual and tried the connection, but all in vain. :expressionless:

Are both of those machines running the same version of MacOS X?
Is the iMac an Intel or a PPC machine?

No… I have configured Mac G5 with MacOSX 10.4.2 and iMac with MacOSX 10.4.6.

But will it gonna make any difference :!: As i read in one of the manual that All the OSX version 10.4 and above will support EG 3.0… :expressionless:

Another customer had a similar issue and it turned out to be a network configuration error.

Please try these two things –

Launch the /Applications/Utilities/Network Utility program
Use the PortScan tab to scan that machine for the VNC ports (5900 6000)
Make sure that your vnc port shows up, if not there is a network problem.

If that works then please try a generic VNC program like Chicken of the VNC and see if that will connect to your windows SUT – if not then VNC has a problem.


I checked with the PortScan method. And its working fine. It shows up the VNC ports. So there is no network problem.

I downloaded two files, cotvnc-20b4.dmg and cotvnc-20b4-source zip file from the site as mentioned. I copied the two files in the /Application of iMac, and after clicking on cotvnc-20b4.dmg, it shows up an warning message saying “disk image cotvnc-20b4.dmg failed to mount” with reason not recognized. Also on clicking the downloaded zipped file it creats a folder named ‘cotvnc’ and another file named ‘cotvnc-20b4-source’.

Actually i’m don’t know how and where to use these files and the correct way to mount these files . :expressionless: What i’m doing is correct :?: If not please explain me the correct procedure.

Also on my iMac i have installed Boot Camp Software to switch between Mac and Windows OS, though have not yet installed Windows OS. Will that creat any problem :?:

I thought of installing MacOSX 10.4.2 and try out again. Please let me know if the above is creating problem :?: If so i’l finally try with MacOSX 10.4.2.

Waiting for the response.

Ok, if the portscan is working then the network is fine.

Bootcamp partition should NOT create a problem.

You should also NOT need to downgrade to 10.4.2 I’m sure we can resolve this via some settings.

Two additional things to try:

I notice you are running RealVNC 4.0 – please try upgrading to RealVNC 4.1.2.

If that fails you can try forcing Eggplant to run under Rosetta. Here’s how you can force a Universal application to open using Rosetta:

[list]1) Click the application’s icon in the Finder
2) From the Finder File menu, choose Get Info (or press Command-I).
3) Select the checkbox named “Open using Rosetta.”
4) Close the Get Info window.

Thank you for your patience with this issue, we have tracked down and identified the problem.

If you are connecting from an Intel Mac to a Windows server there is a bug in Eggplant 3.0 that prevents proper password authentication.
We are compiling a fix at this very moment.

As a temporary workaround you can do either of these things:

A- Set your VNC to be in “No Authentication” mode.

B- Set your Eggplant to run using Rosetta:

  1. Click the application’s icon in the Finder
  2. From the Finder File menu, choose Get Info (or press Command-I).
  3. Select the checkbox named “Open using Rosetta.”
  4. Close the Get Info window.

Thanks for the help.

I changed the VNC setting to ?No Authentication? mode. And glad to say that now EP 3.0 is able to connect to the remote windows machine without authentication from the iMac machine. :smiley:

Please give us a notification when the issue is resolved :slight_smile:

We have posted version 3.01 of Eggplant which resolves this problem.

You can download it here:

Thanks Jonathan for showing so much of patience in sorting out the problem. :smiley:

I downloaded the recent 3.01 version and is working perfectly with authentication. :slight_smile: