OSXvnc can't listen on the specified port (5900).

This is not the only error I receive when I try to remote from my pc to my mac. On my PC I receive a Failed to connect to server. I followed the steps provided by the video I found on the web at:

HOWTO use your Mac from Anywhere [VIDEO]

Which was very helpful but I was also wondering since I am at home and both machines are on the same airport network will I still be able to connect?

Any help would be great!



So that’s a super cool video that’s nicely done and provides a great description of how to set that up.

Unfortunately, as described you will NOT be able to connect from any machine that hasn’t setup an SSH tunnel - because of the step where you check “Only allow local connections [Require SSH]”.

If your machine is behind a firewall and you have ONLY forwarded port 22 (ssh) to the Mac and not port 5900 (vnc) then checking that box isn’t necessary to prevent outside users from connecting since they can only reach the mac via SSH anyhow.

If this is your scenario then you can feel free to uncheck that box and then machines on the local network can still connect to it normally.

Can’t listen on the specified port is probably because you are running Apple Remote Desktop (which also runs on port 5900). You can disable that in System Preferences->Sharing.

So if I uninstall ARD 3 I should be able to connect?
On my airport I have 5900 and 22 open on the mac’s ip address. I did everything else that the video said but I am still getting a “Failed to connect to server error”

You shouldn’t need to completely uninstall ARD, just disable the client in System Preferences.

Since you have setup the SSH tunnel for coming in from outside I would disable forwarding of port 5900 on the Airport. (So external machines can only connect using SSH). Then you can uncheck the REQUIRE SSH on OSXvnc and restart (if you have it configured as a startup item you’ll want repeat that process to note the new flag).

Also would it matter if I was trying to remote from 2 machines on the same network (my home network)?

No, you can connect from multiple machines (simultaneously even).

So since I am at work right now and I can only remote into my PC at home and not the MAC I cannot do anymore testing until I change the settings on the uncheck the REQUIRE SSH on OSXvnc and restart ? It is very frustrating trying to connect my PC to my MAC but I guess it will be worth it once I am done. Also I have 5 machines on my home network so can I be outside of home and still remote into each machine?

Ok I finally can remote but I have to use my ip address and not the dns I got my no-ip.com. I can remote into my pc from work with the domain name I got from no-ip.com but I cannot use the other domain i create for my mac. For example: If I use mysony.com for the pc to remote and to ftp why can’t i use myibook.com to vnc to my mac? I do know that in the video that I watched it had me add 5900 and localhost:5900. Will this have something to do with it?