No keyboard input when trying to log in through VNC client

If I have logged out of my iMac running Vine Server 3.1 and connect to it using any VNC client I get the standard OS X login screen. However, when I click on a user to log in as and am presented with a textfield to enter the password, the keyboard is not functional.

I tried this with both TightVNC on WinXP and CoTVNC on 10.6.2. So this leads me to believe it’s something to do with the server?


You might need to modify your keyboard events settings. Under preferences->Advanced try setting “Hardware Events” and “No Event Source” and see if that works better for you.

I tried that and it didn’t make any difference. I can use the mouse to select the user, but when the login screen comes up with a field to enter my password, no keyboard events come thru. This is the only time this happens. Keyboard events come thru just fine if I am already logged in.

Just FYI, I’ve tried changing the keyboard event options and nothing seems to change the behavior.

When I restart my machine, I need to be able to log in. When I use the mouse to click on my user from the login screen, OS X shows me the enter password dialog. I see that the cursor is in the text field and I start typing, but nothing happens.

Is there a log file, perhaps, that I can look at to see if there is any errors that are coming up?

I’m still having issues with logging into my machine using Vine Server 3.11 and Snow Leopard 10.6.3.

I tried all the different keyboard advanced settings with no change. I’ve attached my login screen. Any other tips? Like deleting some config file somewhere and starting over?