New Ubuntu with Eggplant 22.4 installed and tight VNC

Ubuntu 22.4
Installed Eggplant successfully
Installed tightVNC successfully
When open EP GUI, tried to connect thru VNC
Got an error
…Zlib decompression (stream erro: ())" Sub Component=EPF
Invalid ZRLE decompresson error"

Anybody knows how to fix this?


Could you share some details of the platform / SUT that you are connecting to please? Thanks.

we used ubuntu 20.4 and installed EP 22.1 actually.
when start EP GUI, get connection to SUT as win10.
connection window poppoed up and closed with the above error about Zlib


Have you tried using an RDP connection instead of a VNC connection to the Windows 10 machine?
The environment I work in has Windows server running EP 22.1 connecting to other servers (2008R2 and later) that are the systems under test and RDP works fine. Is there a VNC service running as a task on the Windows 10 host?
Kind regards,

Thanks Jerry,
It worked on our old ubuntu 16.0.
VNC is more convenient since we could share across screen accross the team.

Makes sense. The error message points to the Eggplant host not being able to deserialise/uncompress the data stream it has opened because the compression options used are not compatible between both sides.

I wonder if a normal VNC (server) process started from the Eggplant host can connect to the Windows 10 host?

If it can, then that suggests that the Eggplant binary is using an older (or perhaps newer) Zlib API call with different parameters to what the library supports. If you’re familiar with using Wireshark you could perhaps look at the network traffic between the two machines to see where they get to with the VNC handshake?
Other than that, it sounds like you’ll need to raise a support ticket for this one…
Kind regards