Is this a bug? (TypeText)

run “Open Word” --Opens Microsoft Word
TypeText “Paste Text” – Type “Paste Text” in Word document

Basically, I was just trying to type that text in the Word document in Mac. But it kept on just bringing Project Gallery that has the short key of SHIFT+ COMMAND+P (or \s\ap in TypeText). So I tried TypeText “\S\APaste Text” and it work.

Is this only happening to me? ?

I’m going to go out on a limb and guess that your Open Word script left the command and option keys down in the preceeding script.

You will typically always want to release those keys right after using them, they aren’t released for you. Because sometimes you need to do something like

TypeText "\a" -- Command Down
Click "this"
TypeText "\A" -- Command Up

ohhh… Thank you
I thought that button is released as soon as it moves on to the next line

OHHH this actually solved my problem for the last post I made also…
wow I can’t believe the answer was so simple.

Thank you so much

This made my life easier… D