is launching one VNC server per user account a problem?


Here is my problem (from what I could see browsing the web it should not be a problem, but as I’m completely new to VNC, I may be getting something wrong):

I have a Macpro that I have bought so that a series of users (approx 10 of them) can run dataprocessing jobs on. For some reasons (mostly that the dataprocessing software is in Java), the only solution I have found is to have them connect with VNC.

I’ve downloaded Vine Server, I have created a special firewall exemption case for the ports 5900-5909 (I have also enabled Apple Remote Desktop because I could see on some forum that I should do that).

Now I run on a first account Vine Server and indeed I can connect to this account with Chicken on the VNC… fine

I’ve read that I can in fact run a VNC server on each user account by simply fast user switching on each account and starting VNC server. It works up to the third user (work in the sense that I can start the server, the port number is correctly implemented and a client can connect to it). As soon as I log in as the fourth user and launch Vine Server, the appearance of the Vine Server window becomes strange

  • contrary to the first three instances, when the application starts, the server does not (eventhough Vine Server is configured to start the server at the application launch). The port/display number is correctly incremented though
  • If I change something in the Vine Server configuration (such as the password), even though Vine server tells me I should stop and restart the server, the stop button does not become active ( it did for the previous three instances) and clicking on the restart button does not produce any obvious effect.
  • Indeed when using Chicken of the VNC on the client mac I see the first three servers but not the fourth.
  • Using the network utility on the host mac to see which ports are beeing listened to I indeed see the first three ports but not the fourth
  • Using that same utility on a client mac to check the open ports of the host mac does not reveal the fourth port as well.

So It all seems like I am unable to have more that three VNC servers running on the same machine. Yet nowhere on the web have I seen such a limitation and looking through this forum convinced me such a limitation does not exist. What could I be doing wrong?

Thanks in advance.


PS: I have Vine Server 2.0, the host mac is an intel MacPro running 10.4.8

This should indeed be doable.

The first thing that is important to note is that for the built-in Mac OS X firewall (found in System Preferences0>Sharing) the services entry for VNC only opens ports 5900-5903. If you are using this firewall make sure that you’ve added your own rules to expose ports 5904+. This doesn’t sound like ALL of your problem but it may be a contributing factor.

The second thing to note is that you should DISABLE, not enable ARD in order to use OSXvnc for multiple sessions.

I would verify those first two things and see if you situation improves.

Hello Jonathan and thanks for your reply

I had indeed seen that the “VNC” firewall only opened a part of the port range so I created a personal service called “myVNC” to open 5900-5909. I also opened the same range on UDP though I do not know what it means.

After I posted my message I tried to disable ARD to see the effect (combinatory science is a great way to solve problems I don’t understand!) and indeed found that it was not needed. It did not change my situation however. The odd thing though is that even with ARD disabled I cannot use port 5900, VineServer tells me:

VineServer cannot listen on specified port (5900) probably because vineserver is already launched as a startup service
(translated approximately as I’m using a french version, and on top of that VineServer is not in the items to open at startup).

Now this is where it become very odd because I have checked that I can use all the other open ports (5901-5909) provided I only start Vine Server from three specific user accounts on the host (the admin and I think the first two I created…). This is in fact independent of whether the firewall in on or not.

For instance I have tried lauching Vine Server from account nbr 4 while vine server is only running on the administrator account (and not on the number 2 and number 3 account) and I get exactly the same result: the server does not start eventhough the selected port is 5902, which is a port that “works” for accounts number 1, 2, or 3…

I have tried removing all the other accounts (those for which Vine Server does not start on launch, and does not even start when I click on the start server button) and creating a new one, but even this new one cannot start Vine Server.

So I seem to be running into a very strange problem of interaction with something in MacOS. I’m trying to see if I could have done anything fancy while created the number 2 and number 3 accounts, but frankly I can’t think of anything.


Me again

I found out the reason why I could not use port 5900 was the presence of a copy of OSXvnc (not Vine Server) in /System/Library/StartupItems. This would start as soon as the host mac was booted and occupied port 5900. OK. I don’t remember when I did that, but I could have made a wrong manoeuvre. I’ve removed it and now when I reboot the computer I can check with a client mac that no VNC server is running If I don’t explicitely start one.

In this configuration I have found a new situation: I now have my three “first created” account (that I created when I received the mac) and one that I created today after removing all the accounts on which VineServer would not start (see previous post). Now I can start VNC server with Vine on any of the existing account. This is a much better situation.

However I’m still limited to three servers in total (eventhough I have a choice of 10 ports to use, i.e. I can use ports 5900,1,2 or 5904, 5906, 5909, and so on, as long as I only try three servers…


After some deeper investigation we have determined the following:

Depending on each users settings and permissions it is possible that a shared Vine Server application might not allow simultaneous users to launch it properly. We are classifying that as a bug and will work on a fix.

In the meantime the workaround is for each user to make a copy of the Vine Server application that he can launch independently, we have verified that this will allow many (we tested up to 6) simultaneous connections.

Thanks for the workaround. I’ve tried up to 8 different users/servers and had no problem. I’ll check back to see when this problem is fixed but as far as I’m concerned, I’m fine with the present solution.

Thanks for the support