ImageFound finding text with asprostrophe

I have this string ‘LOAD’ button in my SUT, then I am trying to find if this text exist in the script using the command ImageFound(text:"‘LOAD’ button") but it always return me false. I am able to find the word LOAD itself but when I add the apostrophe around it, the result is not right.

Can we get a screenshot of the graphic you are trying to find? I did a quick test in notepad and EPF found ‘LOAD’ button okay.

Like LoganC mentioned, a screenshot would be helpful in determining the best approach here.

With that said, in some cases Eggplant has a difficult time recognizing the characters depending on font or unusual backgrounds. Using a Character Collection might be helpful for you.

sorry i missed out the screenshot.
This is the screenshot with the text ‘LOAD’ button text in one of the panes.

i tried to set rectangle to a smaller size for the search zone and also tried the Character Collection. But still it cant find the text when I add asprostrophe.

Here are two things i would try:

  1. If the word button is unique to that panel, then search for that:
    ImageFound(text:“button”)

  2. If the phrase ‘LOAD’ button is significant, then try it without the first apostrophe:
    ImageFound(text:“LOAD’ button”)

You could try <<‘LOAD’>>

Hello,
The suggestions to search for “LOAD” are valid. If you find two instances of the text you can use the EveryImageLocation function and click the second item in the property list returned by the function.

Example:
Click the second item of EveryImageLocation(text:“Load”)

For this type of issue I would recommend that you send details to eggplant.support@keysight.com and they will be glad to help.