iMac is sleeping and won't wake up

My iMac (Intel 2008) no longer respects the sleep setting in the Vine Server preferences. That is I have “allow machine to sleep” unchecked in the Devices tab of the preferences. Previously, the screen saver would activate and the display would sleep but I could still initiate a VNC session. Now, it appears the machine is going to sleep. I haven’t changed my Energy Saver preferences. It appears this behavior began with a recent OSX update (.6 or .7 update). Anybody else notice this or have a fix. I am running v3.1 of the Vine Server.

Is the iMac going to sleep directly or is the screen saver appearing first?

It is possible that the mouse is moving to a “hot” corner of the display causing the screen saver to activate, then sleeping afterwards.

If this is the case, then you have several options:

  1. Change eggPlant’s reposition point to something other than the assigned Hot Corner (set the repositionPoint to 0,0)
  2. Turn eggPlant’s mouse repositioning off (set the shouldRepositionMouse to NO)
  3. Change the screen saver hot corner on the iMac via Preferences > Desktop & Screen Savers > Hot Corners

Thanks for the reply.
I was wrong about the order; the display sleeps before the screen saver kicks in. I haven’t changed that or the other energy saver settings.
The mouse is definitely not in a hot corner. I am using the Vine Server so I am not sure about your suggestions for EggPlant settings.
I suppose I could set the energy saver preferences to never let the computer sleep but the Vine Server settings had been working previously. Is it only me or is there some issue with the latest OSX version?