I have no smaller case b

I have a very strange effect on a given conenction to a mac box.

If I type b it does not result in a b, if I type shift b it result in a upper case B.
This happens consistently vs a mac box. There seems to be no other character on this level which have the same effect. Its only the b :?:

Using a different box, like a Win, the effect is not there.

I dont get it…

I will tell you everything of my boxes (versions, platform, setting etc) if you are interested in helpting to solve this mis(t)ery :wink:

Do you get anything when you type a lowercase b? Does it work in live mode? Please tell me which VNC server, OS, and version of Eggplant you are using.

We’ll figure out the mystery. :wink:

Do you have a non-English keyboard on either side of this setup? “International” keyboard configurations can sometimes cause problems like this – it’s a frustrating issue for us as well as our users.

Another possibility is that a modifier key is being included in this sequence (although I wouldn’t think this would be the case consistently), so if you’re unintentionally producing a command + “b” (for example) then it wouldn’t be typing anything. This is also less likely since it sounds like you are connecting to a separate standalone machine.

Just out of curiosity, if you put the cursor where you want it and execute the following sequence, does it produce a “b”?

SetRemoteClipboard "b"
typetext commandkey, "v"

I’m not suggesting this as a viable workaround, it’s just a diagnostic.

I connect from a Mac Powerbook running 10.4.11 to an Intel box running 10.5.6. The Powerbook is set to german keyboard setting as the intel box is. If I switch the intel box from german to us keyboard setting (within finder) the small b appears as it should, if switched back to german keyboard setting nothing appears if I either type or typetext b.

Eggplant (yes I know Testplant) version: 4.11 (1125)
VineServer: 3.0 (1016) How is 3.1beta going :wink:

At the moment I do not use b within scripts, most likely I can avoid using it as long as I want and if I need one I do a copy and paste as I do it for backslashes or @ signs when running vs windows boxes :wink:

I find it so very strange that only the b seems to be affected, why not the a or whatever… I hope it does not start spreading along the keyboard and will affect more and more keys 8)

After speaking with the developers, it seems that the problem is that when using non-English keyboards, we’re only able to see what keys are mapped to; we’re not able to query how to produce a “b”. We ask the remote system for its mappings – if one of them happens to be “b”, then we can type the letter “b”. As I understand it, when using the German mapping the “b” key actually produces an “?” and getting to a “b” requires the use of what is referred to as a dead key. These dead key sequences are not part of the response when we ask the server for its character mapping. The beta version gets a more complete mapping as it attempts to use the modifier keys, but the dead key sequences are still problematic.