How do I configure/run the vncserver on linux

I downloaded the vncserver and installed it on redhat ws 4.0.

I cannot figure out how to configure it.

When I run vncconfigure I get this:
No VNC extension on display :0.0

When I run vncserver it appears to start. However, I cannot connect to it from the Eggplant ‘Connection List’, it complains ‘Failed to connect’

When I run x0vncserver it first complained that no password was configured. I stopped it and ran vncpassword and set a password. I then ran x0vncserver again. It stated that it was listening on port 5900.

I tried to connect to it from the eggplant ‘Connection List’ again and it prompted me for the password. I entered the password that I had set. It still failed to connect.

Please help!

A quick googlin’ for “No VNC extension on display :0.0” returned some hopefully useful links. One of which is this one.

It is possible that you are trying to connect to the default vncserver on display 0, which would be the X server, not the vnc server display. I’m just guessing, I don’t have a vnc server linux machine running here (but will in short order).

I found on the realvnc website some documentation on support the native X (i.e. remoting the :0 display. Which is what I’d like to do. I followed the steps outlined there and I don’t know what I’m missing but it doesn’t work. When I try to connect from the Connection List it just comes back as connection refused.

However, in the mean time I was able to connect to the vnc display that was created when I ran vncserver. I looked in the ~/.vnc/.log and found that that display was listening on port 5901. I connected to it from the ‘Connection’ list in eggplant and I was able to connect to it, however it does not look good. It is just a gray background with a console. This will not work at all for doing GUI testing on this platform.

I think what I really need is to get the native X remoted correctly. But I’m not sure how.


The screen returned by the newly launched VNC server is a completely fresh desktop. It can work just fine but you need to configure your window manager to get started, the specifics of that of course relate to what window manager you want to run.

As for the “console” aka :0 display it sounds like a firewall or port blocking problem, you might want to make sure that you can port scan on 5900 or better yet hit it with a browser on port 5900 ( )and see if you get the VNC protocol return ( RFB 003.00x ).

Well, I’m still trying to get it working on redhat workstation 4.0.

In the meantime I got it working on redhat73.
For that platform:
There are 2 XF86Config files in the /etc/X11 directory (XF86Config and XF86Config-4) I’m not familiar enough with the workings of X to know why. But anyway. Since the version of vnc that is currently downloaded from the Redstone software site is version 4.1.2 then you follow the section ‘For earlier versions’ section for configuring the X server (at this url:

It tells you to copy to the /usr/X11R6/lib/modules/extensions directory. Then you modify the XF86Config to add the options you want and tell it to load the module. For example:

Section “Module”

Load “vnc”

Section “Screen”

Option “Desktop” “Bob’s Workstation”
Option “IdleTimeout” “600”


This caused a bit of a problem for me at first. I configured the /etc/X11/XF86Config file. That did nothing. So I decided to try configuring the other config file in that directory (/etc/X11/XF86Config-4). That did it. I was able to at least get the password prompt when I tried to connect to the machine from the ‘Connection List’ of eggplant. I do not want a password required, so I found that the only change I had to add was to add the Option “SecurityTypes” to “None” in the screen section of the config file. So, the two sections I had to modify in my /etc/X11/XF86Config-4 file were “Module” and “Screen”. This is what I added to those sections:

Section “Module”
… …
Load “vnc”

Section “Screen”
… …
Option “Desktop” “auto-redhat73”
Option “IdleTimeout” “3600”
Option “SecurityTypes” “None”