Hi everyone,

I?m new here and I use Eggpant Version 3.01.

I have Eggpant adopt from a colleague for a view days. Now I have Problem with the Helpers-Suite. In this suite are some scripts for every Test we have. Now Eggplant give me an Error Message when the script call the Helpers suite:
NSInvalidArgument Exception
Script replace CharaktersInRange: nil NSString is given.

I guess, something in the Preferences is wrong…? Or?
Can someone help me?


Can you tell exactly where the error occurs? If you turn on Script Tracing that may help you to identify it. It looks like you may be running into a bug (you are using quite an old version of Eggplant). We may be able to help you work around the problem if you can provide more details.


yes, I can tell it exactly. I have 10 suites and one suite calls the Help-Suite. In this suite I have some scripts for every suite I have. And the Help-Suite is linked (Helpers) with the most suites. In the Help-suite are no names with special characters or space (like discriped in the User Guide).

Every suite has a main-script. The main-script includ scripts from the same suite and scripts from the Help-Suite. When I start the main-script I get this error message when one of the sript in the Help-suite is called.

I make a test-script in the suite with the Main-script and test it with the “Run” command (drag script from the Help-suite in the test-script) and it works.

I know that the Version is an older one… I have Eggplant 3.3 also on this System. I don?t know why my colleague woks with this Version.

Sorry for my english I?m from germany… I hope you understand what I mean. -Thanks for your help-


I’m having a hard time figuring this one out. Perhaps you can provide some more details.

Try running the problem script in the debugger. Set a breakpoint in the main script just before the line that calls the script in the helper suite. Then click “Step Into” repeatedly to see exactly which line is causing the error.

Does the error occur on the line in the main-script that calls the helper script? Or does the helper script load and the error occur after it begins running? If you can post the actual script line that causes the error, and the exact error message, maybe we can figure out what’s causing the problem.

I have attached a screenshot with the error message.
The error occur in the line in the main-script that calls the helper script.

Can it also connected with the license?
First, everything worked, and after the administrator work on this computer, I got the error message. He said to me that I have to re-enter the license key.
I made it but a warning appears that the key is wrong and Eggplant further run and I got no other message.

Here two more Screenshots.

Some more Information about htis Bug.

The message occurs when…

  • Main-script calls the Help-script in the Helper-suite.
  • A script call another script in the same suite!!

Eggplant Version 3.01
MAC OSX version 10.5.2
Prozessor Dual 1.8 GHz Power PC G5 1,25 GB DDR SDRAm.

I hope you can locate the error.

When I use the Run Command and the path all scripts are running. I test it with the Helpers-Suite and scripts in their own suite. When I only use the name from the scripts nothing works.

Ok, now it works…

It was a licence problem.

Excellent! I’m glad your problem is resolved. I think the error message given by Eggplant wasn’t very helpful, so we’ll take a look to see if that’s something that we can improve in a future release.