getting RemoteConnectivity problem

Hi, I am new to eggplant, i am trying to run scripts through command line. I have given command like this then enter at command line. then license is getting checked, but then getting the Remote Connection unavailable issue. could any one help me plz. (I am using eggplant 10 ver with linux, but trying to access through windows machine where my VNC client is running, Also note that I am trying to connect through my windows desktop using Xming tool)

There is no default connection – you must either specify the connection information on the command line (see the topic “Running from the Command Line” in the Eggplant Reference) or use a connect command in your script to tell eggPlant what machine to run against.

Thanks Matt, Could you please give me syntax for the two ways you have explained?
Any ways, I have tried by giving login credentials with the same command, which i have mentioned in the above issue. But you know what happened, after issuing the command, it is not at all allowing me to open the eggplant application. No Error messages and no exceptions. Also, from normal command is not giving me to open the eggplant now. What could be the problem? Was there any session running with the same username which i have ran earlier, if yes i have to kill it, right? how to do it?
Finally you know the problem I only getting, not others they are freely opening the application and doing there normal flow of work. I hope you have understand my problems which i am facing now, hope you come with some solution . . . thanks in advance

This particular aspect of eggPlant is very well documented. For the command line:

Connection Information (-host, -port, -password)

Use: Identifies a specific SUT on which to run your scripts.

Example: /Applications/ /Users/Alex/Docs.suite/scripts/myTests/test2.script -host SUT1 -port 5901 -password broncos
and for the Connect command:

Examples: Connect ?
Connect (serverID: “RedHat-test”, portNum: “5902”, Visible: “Yes”)

Parameters: A host name, IP address, or display name from the Connection List.

Alternative Parameter: One connection property list.

I’d understand the problem with eggPlant launching if you were running it on a Mac, but I’ve never heard of it happening on Linux, and if it did, it would have to be for a different reason than on the Mac. It sounds like you tried launching the app in GUI mode from the command line? If not, try entering just “eggplant” and see if there are any messages. I’d recommend restarting the machine.

You can look for running instances of eggPlant by running the command:

ps auxww | grep -i eggplant

Thanks Matt, Yes I have tried with the same command, but without giving the port number. Any ways, i will try today also.
Next, I don’t have any Mac Matt, actually eggPlant is on Linux, and I am trying through my windows machine, the third one also windows machine where Real VNC is running.
Yes Matt, I am issuing eggplant(enter) command at prompt. It is trying to get some thing with xming, but not displaying any thing.
You said to restart the machine, is it eggplant server needs to be restarted once?


I understand that you don’t have a Mac, I was just saying that I know of an issue somewhat like you describe, but it only affects the Mac as far as I’m aware.

I don’t understand your configuration – what is the Windows machine in the middle for? This should be a direct connection from eggPlant to your Windows SUT.

I meant that you should restart the machine on which you are running eggPlant.

Please note: This is really a time-sensitive support issue and should be handled through e-mail to support, not through the forums. You should also contact us using your company email so that we can add your case to the database so that both you and we can track its status.

Thanks a lot Matt for your kind support.