Eggplant keeps ignoring the Click command

Hello, I’m writing test script with Eggplant on Mac. I’m keep on having this problem after I upgraded to Eggplant 3.3. For example, when I try to select an object located at (100, 100) I type Click (100, 100). It works perfectly if I run this line of code only, but sometimes it ignores the Click command when I try to run it with other codes together. It looks like the pointer is just on the top of the location that it suppose to click and just go on to the next line of code. Only way for me to run my script now without getting error is to run the line of code that has that problem seperately by clicking Run Selection for each line(It works perfect this way). My old scripts are running fine, but the new ones I have created after I upgraded is having this problem.
Please help!

This sounds like a timing problem. When you use coordinates to click at a location rather than specifying an image, Eggplant will perform the click right after the preceding command, waiting only for the remoteWorkInterval which may not be long enough in this case.

You may want to change this to click an image instead, which will ensure that the object being clicked on is present before the click will occur. Or you can increase the delay in another way such as by increasing the remoteWorkInterval or inserting a brief wait command in your script before the click.

Yes, I thought the problem is timing also. So I tried all of the following
Wait 3 sec
Click (100, 100)
Wait 3 sec
Click “image”
Waitfor “image”
click “image”
Click (100, 100)
Click (100, 100)
Click (100, 100)
Click any white space many times then clicking the object(This
sometimes helped)
DoubleClick “image”
Selecting the object by dragging(This helped sometimes also)

It never happen to me before I was using 3.21. Please tell me if there is a link to download that version. I want to try if that version works better.

I don’t believe there is anything different in Eggplant 3.3 that would lead to your problem, but you can get Eggplant 3.21 if you like and give it a try.

Whatever you find, please email support (at) redstonesoftware (dot) com with your actual script and results log so we can better diagnose the problem.

The Click command works with names of images (to find) or with a coordinate. If you are clicking at a location it needs to be absolute to the desktop/screen. Ensure you have a point, that is indeed a valid point, and go from there.

We’re glad to see that it turned out to be a problem with the Command and/or Option keys being held down.

See Post: