Eggplant confused about directory structure

I am neck-deep in a problem trying to figure out why Eggplant will decide at some point, after running correctly, that it can no longer find a script from another suite when I ran into a real whopper!

I’d like to send the screen capture, but can’t do that here, so I’ll describe it. I’m shortening the real paths for my sanity.

In the script editor, I told Eggplant to Save. I navigated to my /data/ejamesbe/Egg/Env.Suite directory. The Eggplant Save dialog shows that it thinks this directory contains the files that are really in /data !!!

Just to make sure I’m not nuts from banging my head against this problem for WEEKS, I used Finder to look at the /data/ejamesbe/Egg/Env.suite directory and it contains what really is there - the stuff that’s supposed to be there - Eggplant Suite stuff - the correct Eggplant suite stuff.

What the heck?

The problem I need to fix is why Eggplant gets confused and can no longer find a script that it has found in previous runs.

I will post that problem, with command line output in another post.

I’m saving the picture of this problem in case someone from Redstone wants to see it.

I just now tried navigating from the Eggplant Save dialog down into that wacky directory structure and it is an infinite loop, as the problem above would imply.


Yeah, this isn’t a problem that we see or have reported regularly. Please send the screenshot to the support email address at