Eggplant and VNC connection problems


we are using your software here to test our products. Unfortunately, I have some problems connecting to two virtual machines with Win32 and Win64 clients (Vista and Win7 repectively).

Both machines run a script, which is running from a mac machine using the lastest Eggplant. They open the explorer window, enter some path, then press enter. After this enter, nothing happens for about two minutes, then I get the message: “Script error, connection problem, operation timed out”. This ALWAYS happens.

After this message, the script can run again to this point and the desktop is actually usable when trying to use it after the error message.

Both machines are mostly blank, having just most recent patches and latest UltraVNC running. I tried RealVNC with the same result.

I hope you can help us, this is a real problem, since one can’t tell why this happens.


First, this is an issue that you should really contact us by e-mail for; the forums are intended for less urgent issues that the eggPlant community might be able to assist you with. Customer issues submitted via e-mail receive top priority.

We’ve tried unsuccessfully to reproduce this issue. You should first make absolutely sure that you’re not still running against UltraVNC – we have had occasional problems running against that server. Did you actually shut that server down? To be sure, try running the RealVNC server on port 5909 so that you know you are running against the right server.

You should also check the Console for error messages related to eggPlant or the VNC connection. There may be some clue there as to what is happening.

Can you send us the actual script you are running? It sounds pretty straightforward, but maybe there’s something odd about it. One other thought: You might recapture the images, particularly if there’s one being used in the command right before where the error occurs. I have seen one instance where an exception was reported as a connection problem, but it was actually a different issue that was being misinterpreted in the code.