Dynamically generated string - incorrectly read by OCR

I am using OCR search to read text from SUT. This is a dynamically generated UUID. I am using enhancedLocalContrastOn. But my test still fails. Please help.


Have a look at this video link and maybe it can give you some pointers in the right direction.
There is a section post …8.29 mins into the video about text that can become hard to read using OCR.

Hope it helps and good luck.

I had already watched the video and after trying the tricks in that video was able to improve the readtext result from 20% success to about 90% success, but since I couldn’t get it to 100%, I posted the question here.
How to fix the issue where digit ‘0’ read as letter “O”?
And I cannot understand why OCR has introduced space before the last character?
I don’t know if there are any more tricks or anyone else has faced similar issues.


I too observed that the accuracy of the OCR is less… Can you let me know what all options you have tried to read the text.

So, i can give you any alternative option if its possible.
Additionally, is the patter is fixed ex: AAANNNAANN-AAN (A - Alphabet and N for number ) or not ?


The field I am trying to read is a text field. Actually, it is supposed to display item name, however if name is empty, it displays the UUID. So there is no fixed pattern. It can be this long alphanumeric string with dashes or a simple “My Test 123”.
I tried contrast, contrast color and contrast tolerance - with no good results (Note here that as a new user, I don’t understand these concepts very well.)
Ultimately, “enhanceLocalContrast:on” provided the best results - still not 100% accurate.
Also, I have set searchrectangle before calling readText.

I am adding another example with different name. This one is only displaying numbers. Why are letters not captured?

If the text is in a selectable field, you may have better results using the RemoteClipboard function (http://docs.eggplantsoftware.com/ePF/SenseTalk/stk-keyboard-clipboard-events.htm). Just click in the field, type Ctrl-a to select the text and Ctrl-c to copy it, and the exact text should be available from the RemoteClipboard.

1 Like