Connect to Mac OS X 10.5.6 VineServer 3.0 from PC using VNC

Hi All just need a little help!

I am running a iMac 20" Intel Core 2 Duo at “HOME” with Mac OS X 10.5.6
Vine Server 3.0

I have a iMAC 20" Power PC G5 at “WORK” with Mac OS X 10.4.11
Vine Server 3.0

I also run ARD 3.0 on both machines with port 5900 and 3283 on both protocols TCP and UDP

What I can do:
Connect from WORK to HOME using ARD
Connect from HOME to WORK using ARD
Connect to WORK using Real VNC Viewer on a PC Laptop via Vine Server 3.0

What I can’t do:
Connect to HOME using Real VNC Viewer on a PC Laptop via Vine Server 3.0

I also should note due to VNC wanting to use the same port 5900 by default; when using ARD you get the following notification:
The computer ?IP ADDRESS? is running a VNC server that does not support Remote Desktop keystroke encryption. Text you type to this computer may be intercepted over the network. Do you want to continue connecting anyway?

When VINE SERVER 3.0 is deactivated on both MAC machines I can still connect to from MAC to MAC both ways using the ARD client

The “HOME” Mac is connecting to internet using a modem with PPoE(LLC) and I have set up port forwarding ( for VPN, VNC and RemoteAnything ) to my router.

Trouble shooting:
I have turned off Firewall on both Modem and MAC - Still no connection
I have run the following script on the “HOME” Mac and it recognises the Vine server

This all works under Mac OSX 10.4.11 so I’m under the opinion it’s a Mac OSX 10.5.6 issue

Help would be greatly appreciated

First of all, you didn’t mention how you have Vine Server configured, but if you’re running ARD you’ll have to run Vine on a different port (typically 5901 or higher) since ARD always uses port 5900. Then configure your VNC client to connect to that port. You’ll also need to make sure the appropriate port(s) are open in your firewall settings, router port forwarding, etc…

Have you tried turning ARD off? Most people run one or the other (either ARD or Vine) not both at once, although you can if you configure things properly.

Hi Thanks for your response.

At “WORK” i have the Vine Server 3.0 configured as default install on PORT 5900
I have not added any extra port forwarding other than the standard requirements for ARD

If I have Vine Server running, ARD will connect using Vine server - with the notification on the first post of this thread. Just hit [Continue] and it just connects.

If I Turn off Vine Sever, ARD will connect using it’s default ARD client server.
I’m not aware of any settings that allow you to turn this off on the MAC

With the above setup I can login remotely using Real VNC from a PC laptop.

Being that this works - I have setup the same at “HOME”

The current “HOME” Vine Server setup is configured on port 5900 as per the “WORK” setup (which works - as described above)

I have setup and tested port forwarding from the modem to router on both PORTS 5900 and 5901 with no response. I’ve tried with Firewall turned off and with the firewall allowing connections for ARD, VNC, VINE OSX Server.

Port forwarding must be correct on both modem and router as I can connect using ARD on PORT 5900 through VINE SERVER 3.0 on both HOME and WORK

On the “HOME” computer if I run this
The Vine server is visible! So I know I should be able to connect to it!

The only variance I can see are:
Mac OS operating System

Any thoughts!

After some extensive trouble shooting
I think I have solved the problem!

Using JollyFAST VNC on the “WORK” MAC I was able to connect to HOME
So I installed ULTRA VNC on a PC at work and also connected to HOME
So when I got home last night i tried the PC laptop - connection got rejected. Doh!

So I uninstalled ULTRA VNC on the PC Laptop - rebooted - and did a clean install. The response was a little better…
But not quite there!

Tuns out that at home, the PC laptop is connected wirelessly to the network. So instead of using the external IP address it needs the internal IP address :oops:

I feel like a complete idiot

Thanks for everyone’s help :smiley: