Can't Run my Eggplant after I updated my Mac OS X

Today I updated my Mac OS X from 10.6.8 to 10.7.2; then I tried to start my eggplant, I got following error message: “You can’t open the application Eggplant because PowerPC applications are no longer supported.”

Then I also updated my Eggplant to V11.11, I still got same error message.
Does any one have the same problem, how do you solve it?

Thank you in advance.


We cannot run our automation at this time…Thank you in advance

Very strange, eggPlant has been shipping a Universal Binary since version 4, the only thing that I can think of immediately is that it’s been specifically tagged to run using Rosetta (in PPC emulation) but that definitely is NOT required or expected.

You might read this post ( and try to reverse the process to “un-set” the flag that is forcing it to run in PPC mode.

This definitely isn’t a typical issue – almost everyone is running eggPlant on Intel hardware these days.

You might also try running as a different user or on a different machine just to verify that your download is valid.

To follow-up on this issue.
In Mac OS X you can explicitly set an Application to run in Rosetta via the Application’s Info Panel. This slows eggPlant down in Mac OS X 10.6 and just doesn’t work in 10.7.

To correct that problem try this:

  • Highlight in the finder
  • Hit Cmd-I to bring up the info panel
  • Uncheck the “Open using Rosetta” checkbox

Apparently after trashing this file(~/Library/Preferences/ and rebooting, it works.

Thank you very much for all your help.