Cannot use AltKey & function key combination in TypeText

Hello, hello

Can someone give me a hand here.

The code looks like this:

TypeText AltKey & f2

When run against the SUT (Ubuntu 804, gnome desktop) nothing happens.

If I manually press the ALT key and the f2 key the run dialog appears (this is what I want to code).

Now, if I change the shortcut on my SUT to be the Ctrl key and f2 then running the code like this…:

TypeText ControlKey & f2


Where am I going wrong?

The situation is that the Alt Key on Mac and the Alt key on Windows/LINUX aren’t the same key. I think you want to do:

TypeText WindowsAltKey & f2

Thanks, that worked a treat.

I am having a similar problem using RedHat 6 and Eggplant 12.2

TypeText AltKey, f2

When I run this command, nothing happens. The “Last Run” window shows
typetext [windowsAltKey][f2]

I have also tried
TypeText WindowsAltKey, f2

This used to work on Redhat 5 and Eggplant 11.3

We definitely haven’t changed anything about how eggPlant sends those codes and it should not rely on anything platform specific.

So if it worked on v11 on RH 5 it should work with v12 on RH 6.

Has the SUT changed at all?

The SUT is now Redhat 6.2

Does it make a difference if the Eggplant is run from a KDE or Gnome desktop?

The desktop for eggPlant shouldn’t make a difference, but the desktop of the SUT could.

Are you able to send that key combination in Live Mode? (And produce the effect you are looking for).

This is just a guess, but with some desktops the placement of the mouse is important for certain events on the SUT (eg Sending the ScrollWheel). You might need to precede your TypeText with a MoveTo to make sure the mouse is where you expect it to be for that action.