Cannot able to run the script with the highlighted lines

Please correct me if this is ‘User Training’ issue.

Being a new user to EggPlant, all I’m trying to edit the script, save and make sure the edited lines actually work during the script execution. So part of this process, Once I save the script, I usually highlight the part of the line that I recently modified and press [Run Selection] to confirm the execution process.

So I see the [Run Selection] button greyed out for some reason which means I cannot run the script. Tried to close other scripts and opened the recently edited script and again tried to run but this time it actually works so pass. But again tried to run same script line with the highlighted but [Run Selection] is greyed out again.

Am I doing anything wrong here? Would love to attach a video that describe the process but can’t due to the restrictions for “File Attachment”.


When you edit a script and select a line to run, the “Run Selection” button should become enabled. If you have another script running at the time, you will see a red “Abort” button that will allow you to abort a currently running test, and the “Run Selection” button will be disabled.

If you are seeing behavior outside of this, you should write in to support and send the associated video to describe the process.


Thanks, already raised an issue with support, lets see the comments.