Black Video if Compression is turned of


i’m using eggplant 10.23 under OSX 10.6.5. I tried to turn the Movie compression off (defaults write Eggplant MovieCompressionEnabled NO) and now the recorded movies only show a black screen (only the cursor is visible). After turning the compression on again, the recorded videos are working again.

the compression feature is nice, but damn slow (core i7), so please tell me how to disable the compression and get a working video.

thx, br klemensl

Unfortunately that seems to be an incompatibility with the 10.6 QuickTimePlayer; those same movies will play under 10.5 and also with other third party players.

The compression is being done by a separate tool called qt_export. The qt_export file is inside the wrapper. There are some hooks that will allow you to control the settings (and undoubtedly improve the speed).

First you need to create a settings file, you can do that by bringing up a QuickTime dialogue:

qt_export --dodialog

Then you can specify for Eggplant to use that file with

defaults write MovieSettingsFile

If you find some good, fast settings that work for you please feel free to post that file here.

alright, i have tried to watch the uncompressed videos under 10.5 - works. better than nothing…

how about implementing a switch in the StopMovie Function? StopMovie(boolean compressVideo)? Or how about compressing the video in a parallel thread?

before you have implemented the auto compression, we called qt_export after stopping the move, but because of the real poor performance, we disabled the compression again.

i have created just a small .app which calls qt_export with all video files dragged on it. so we can convert all videos after the test.

br klemensl