Atlassian Bamboo integration?


We use Atlassian Bamboo as part of our CI process. Looking at your eggPlant integrations page there’s a Bamboo logo but my understanding is that this is just via the command line interface?

Is there (or are there plans for) native Bamboo support to allow the eggPlant test results to be parsed by Bamboo and reported accurately? Alternatively is there a way to generate test output in Bamboo-friendly format (e.g. JUnit).

Many thanks,

Yes, our current integration with Bamboo is via the command line.

We do have plans to provide more direct integration in a future release of eggPlant, but cannot give an ETA at this time.

As of version 12, eggPlant generates script results and statistics in XML/JUnit format, which should be useful as far as ‘Bamboo-friendly’ formatting goes.

That’s great - thanks for the reply.



This is probably because the user that Bamboo is executing as is not the same user as when you run command line. There are two possibilities.

The first is that this user does not have access to the License files (normally stored in C:\Library\Eggplant). Please make sure those license files are readable by your Bamboo user.

It could also be that your licenser host is located in an external network, you might have specified this in the GUI for your user but not the user that is executing the Bamboo process. In that case you could specify this as part of the trigger script by including -LicenserHost IP_ADDR in the call to eggPlant.

Hi JonathanOSX,

JonathanOSX ,

I have added LicenserHost IP_198.@.@.@ into my script file even bamboo is not able to trigger the bat file.

Error launching task: C:\Program Files\eggPlant\\Resources\EggplantFLS.exe … NSOSStatusErrorDomain 193

Unable to contact Team License Server

getting this error…

Please give me your valuable suggestions.

You just want a plain IP Address, don’t have IP_ in front of it.


So the license file should be at C:\Library\Eggplant

It’s probably already there, but might not be readable by your Bamboo user. You might paste the full text of the console when you try to run eggPlant from Bamboo, there may be other messages that are important.

Actually it is referring EggplantFLS file for license. But it doesn’t contain anything.

Can I paste the License (C:\Library\Eggplant) to EggplantFLS file. So that it is readable to bamboo…[size=7][/size]

No, the EggplantFLS should not be overwritten, that is not the license file.

Please post the entire error message or send it to

Hi JonathanOSX,

Working fine from bamboo…

Very thanks .

A quick follow-up question about the command line for Bamboo: I see mention of C:\ drives and .bat files, but do you have OS X compatible scripts too? Obviously this is for testing iOS mainly, but we also build our Android app on a Mac Mini.


So, the .bat file we provide is runscript.bat. On the Mac you can still make call eggPlant via command line but it’s just the “runscript” executable.

That should allow you to call eggPlant scripts from Bamboo. For more information you should refer to [url=]Running From the Command Line

Hi JonathanOSX

Actually I am using one VM machine which is placed in US. From that machine I have to connect the eggplant SUT machine (IP address are different)
When I execute from command line it is executing sucessfully.
By using Bamboo, getting error like "Unabale to Connect to "

Please give me any solution for this issue.

This is almost certainly a networking issue between the machine running bamboo to get to the SUT, but we would need to know specifics. Since this is a question specific to your environment it would be best to contact support directly.

Hi JonathanOSX,

I have two machines one is corporate network and another one is Lab network.

  1. If I run from VM(placed in US) to corporate network machine via command line it is executing sucessfully.
  2. If I run from VM Bamboo (placed in US) to corporate network machine it is executing sucessfully.
  3. If I run from VM(placed in US) to Lab network machine via command line it is executing sucessfully.
  4. If I run from VM Bamboo (placed in US) to Lab network machine via command line it is getting error.

I think no access from Bamboo user to Lab machine.
Can you please give the solution for this problem. It would be very helpful .

Thanks advance