Windows Server VM SUT crash

Setup: RDP into eggPlant server (Windows Server 2012), then to test client SUT (VM with Windows 7 Professional).

I have scripts that have worked in the past, but now updating to a new machine w/ different resolutions. For the most part, I run the script until it fails, then recapture image to make the update. Every now and then, I will rescript to make it more elegant or just retake an image b/c the name of the images doesn’t make sense to me now.

At random, when I try to CAPTURE IMAGE, the SaveImageSheet will not popup. If I hover over eggPlant on the taskbar, i can see it, but can’t select it. At these times, I also cannot close the windows with the close button. I have to end process via Task Manager.

Once eggPlant is reopened, changes that were made and saved with File>Save All are not there. The scripts are reverted to their previous broken states. There is no indication as to when eggPlant stops responding and is no longer ACTUALLY saving my work, except when the CAPTURE IMAGE function doesn’t work.

There was one other indicator, just once - I updated a script that was called in another script. But when the script called the updated script, only the older version would execute. I broke the link in Settings and relinked it several times, but no luck. So, I went back to the updated script and verified the changes were there, did Save All. I closed eggPlant and went to the updated script, and the changes weren’t there. Again, it’s like eggPlant wasn’t responding but didn’t tell me it wasn’t responding.

Has this been observed before? I have not email logs or submitted a report yet; my system engineer is looking into it first to make sure it isn’t a hardware issue.

It sounds like you are running v15.21 (although I’m not familiar with all of the symptoms that you have listed.) We released 15.22 last week which addresses an issue that could cause not being able to save images among some other problems. If you have not done so, please update to 15.22 and let us know if you still see any of these problems.

We’ll give it a try, and I will keep you updated. Thanks!

The crash with same symptoms described below happened again. I couldn’t get the email to work, so I attached the logs here. Any insight will be helpful. Thanks!

Was the crash log received? I didn’t see it attached to my comment.

Please send your report and crash log to the TestPlant support address.