VNC/Vine/leopard server and desktop backgrounds


Can anyone tell me what is going on here?

I used to use osxvnc/vine when I had Tiger server. After using both ARD and applevnc for a while with leopard I’ve decided that it uses too many resources to be particularly useful so I went back to using Vine (3.0)

When I have a monitor connected to the machine, vnv/vine shows the background perfectly but when I disconnect the screen after reboot the background goes back to aqua blue.

Can anyone tell me how I can disable this feature? I realise its a good idea over low b/w connections but I really don’t have that problem and would prefer the ability to turn it on. As you can see I obviously have a background selected.

This isn’t a Vine Server feature (although we’ve considered adding something like this).

It’s actually an Apple Window Server behavior where it stores different backgrounds based on the “connected monitor”.

I don’t have a well researched solution, but something with the apple defaults might be able to solve it.

thanks for the additional information.

The big problem I’m having is that this isn’t exactly constant across the board. Before I reinstalled Leopard I was able to have a background if I logged in using the login screen but not if I had an autologin set. It sometimes would let me change the resolution and sometimes when I did I’d lose the background.

cheers for the extra info.

If anyone else can point me in the right direction or knows why this is going on and how to change it I’d love to hear.


actually, just to ask…

do you know if this is an OSX server thing? or does it happen with the client also? I see so many posts talking about changing osx background to speed up the client refresh … but no posts asking to reverse that…

When I login to the macbook pro from the server I get the background working perfectly… but not on the server.

I realise that this is really material… but I’m a bit annoyed that I don’t even seem to have the choice.

It’s not just Mac OS X server, it happens on my Mac OS X client machine as well. It may depend on the hardware you have, as part of the whole “detect which monitor” thing.

well guess what I’ve still been trying to find a solution to!

I’ve found this out so far…

all I need is to force a background for goodness sake… how hard is that? really? (I’m not dissing redstone here)

Problem is, I vaguely remember that if you short a pin or two I believe you can get it to force a monitor without that contraption… I just dont remember where I saw it :expressionless:

anyone techie enough to know what defaults to force?

cheers, Ian.

sigh still looking…

what made me think about this again was that I was downloading the update to 10.5.8 server reminded me that it works when its updating…

I know its such a small thing, but that’s what makes me think it must be so easy to fix when the server can do it when it wishes :frowning:

Just to be really clear – Vine Server/OSXvnc does NOT have any logic in it that is removing or requesting the removal of the background. It’s the OS doing that in the frame buffer that the server is receiving (for it’s own obscure purposes).

You may be right that there is a simple way to request that it stay present, but if so I haven’t run into it, if anyone finds it I’ll be happy to slip it into the server as an option.

Here was a page with instructions to short a Mini’s DVI plug:

There is also a way to explicitly run a screen saver for the desktop (including one that just shows a background image), I can’t recall it off the top of my head though.