Vine Server will not load

I have Vine Server installed for over a year now on a Mac Pro, Quard Core. I recently try to load Vine Server to play with the configuration. Vine server will not load. When I click on the app, Vine Server tries to load, but eventually all that appears is an icon in the Dock. If I force the application to quit, and then reload, the same problem persists. I have tried to reboot my computer, turn off, still same problem. I even tried downloading the beta version, and the same problem exists. Finally, I tried deleting the application and all the settings, rebooting, and then redownloading the server again. Still same problem. Any idea how I can resolve this issue?

Please do the following:

  1. Delete all instances of Vine Server (OSXvnc)
  2. Remove the defaults with “defaults delete OSXvnc” using /Applications/Terminal
  3. Reinstall the latest Vine Server in the
  4. Report back to us what happens.

Please also provide what is in your system output log files that are related to the OSXvnc and Vine Server applications.

Thanks for your reply.

I used the “defaults delete OSXvnc” command in the terminal. I then re-downloaded the latest Vine server 1.2 beta. When I try to load it, the same thing happens. When I look in the System log, I do not find anything related to OSXvnc or Vine server. Any other ideas?

If you are you running any Haxies based on APE. FruitMenu, ShapeShifter, etc. they have been known to corrupt Vine Server to the point where it cannot run. Similar to what you are describing here.

If you are running any of those, after uninstalling Vine Server, try setting Vine Server to be “excluded from APE” using their menus.

If that doesn’t work (or you aren’t running APE) then try using a different user account to download and run Vine Server (in a different location) and let us know if that works any better.

I do not have any Haxies installed. I tried to download and start Vine server from another user account, and all attempts yielded the same results- Vine server will not load. Any other ideas? Thanks again for your help.

That’s very peculiar. I don’t know of any other reason that would be occurring. A few things to try:
1- Make sure that you are downloading directly from the machine you are installing on.

2- Download a fresh copy to a new directory and unpack/run it in a new directory as well.

I have tried creating a new folder and putting a newly downloaded Vine Server into it (downloaded directly to my Desktop) and Vine Server still will not load. It is very strange. I am running 10.4.10, do you think that could be part of the problem?

Nope, 10.4.10 is certainly not an issue, we are all running that.
Please do us a favor so that we can further diagnose this problem:
When you launch Vine Server would you use the Activity Monitor application to capture a “Sample” of Vine Server and send the result to support at redstonesoftware. That should help us figure out what’s going on.

same problem, 10.4.10, brand new macbook pro, dock icon bounces several times doesn’t open

Analysis of sampling pid 246 every 10.000000 milliseconds
Call graph:
    300 Thread_0f07
      300 0x87f1
        300 0x88ca
          300 NSApplicationMain
            300 +[NSBundle(NSNibLoading) loadNibNamed:owner:]
              300 +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:]
                300 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:]
                  300 old_loadNib
                    300 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:]
                      300 -[NSSet makeObjectsPerformSelector:]
                        300 0x993f
                          300 0x9164
                            300 +[NSHost currentHost]
                              300 getnameinfo
                                300 _lookup_all
                                  300 _lookup_all_secure
                                    300 mach_msg_trap
                                      300 mach_msg_trap
    300 Thread_1003
      300 _pthread_body
        300 __ape_agent
          300 mach_msg_trap
            300 mach_msg_trap
    300 Thread_1103
      300 _pthread_body
        300 forkThreadForFunction
          300 0x8f9f
            300 +[NSHost currentHost]
              300 getnameinfo
                300 _lookup_all
                  300 _lookup_all_secure
                    300 mach_msg_trap
                      300 mach_msg_trap

Total number in stack (recursive counted multiple, when >=5):

Sort by top of stack, same collapsed (when >= 5):
        mach_msg_trap        900
Sample analysis of process 246 written to file /dev/stdout
Sampling process 246 each 10 msecs 300 times

edit: in the time it took to type this and take the sample the application window opened but it is apparently frozen

We believe the cause of this lock-up is that your computer is getting stuck trying to resolve its own host name. This almost always happens due to some DNS inconsistency. Try checking the DNS servers that your computer is set to use (on the Network pane of System Preferences), or try checking what values you have set for the search domains (Network) and Host Name (Sharing).

similar problem, solved it by renaming my computer under Host name