Vine Server problems on Leopard?

I’ve been having a lot of problems with Vine Server since upgrading to Leopard. I made sure I’m running the latest version (3.0 (1016)).

Most often I simply can’t connect to it and I’ll get an error on the client: “unable to connect to host: Connection refused (10061)”. When I look at the machine locally, I find that either the server has simply stopped with no explanatation or, lately, the message “Screen Resolution changed - Server Reinitialized”. In either case, the server doesn’t seem to restart itself, but manually doing so will work for a while.

A bit of background, for what it’s worth: We use our machine to manage 8 users, all of whom need remote connectivity. So we actually have 8 instances of Vine Server running, each on its own port. (We just copied the application into each user’s home folder to run their instance from there.) This has generally worked very well for us.

Also, I’m running Leopard 10.5.2.

Thanks in advance for any help you can provide! :smiley:

Interesting… first can you verify that “Restart server if it stops unexpectedly” is checked?

[quote=“JonathanOSX”]Interesting… first can you verify that “Restart server if it stops unexpectedly” is checked?[/quote]Thanks for the reply, and sorry I didn’t mention that. That’s been checked (and double-checked ;)) lots of times while figuring this out on our end.

k, I figured so – it seems like there might be a bug in there. I’m looking into the problem now and will let you know.

[quote=“JonathanOSX”]k, I figured so – it seems like there might be a bug in there. I’m looking into the problem now and will let you know.[/quote]Thanks so much. Let me know if I can test anything–beta packages and the like. I’m pretty open to anything at this point. :slight_smile:

im having the same issue. I am running 3.0 and have the option start server(not system server) and for display number 1 and port 5901.
Start server when application launches and have this for my login startup.

When the application launches it does not start the server. I have to come in on port 5901 (apples remote desktop) and restart the Vine server application. This worked fine in 2.x.

To add info this is what is running before i manually start the vine server

ps -ef | grep -i Vine
501 178 101 0 0:00.17 ?? 0:00.75 /Applications/Vine Server -psn_0_114716

After i click start server in vine, i get this

501 491 471 0 0:00.00 ttys000 0:00.00 grep -i Vine
mac:~ joe$ !!
ps -ef | grep -i Vine
501 178 101 0 0:00.36 ?? 0:02.67 /Applications/Vine Server -psn_0_114716
501 492 178 0 0:12.48 ?? 3:42.59 /Applications/Vine -rfbport 5901 -desktop imac -rfbauth /Users/joe/.vinevncauth -alwaysshared -allowsleep -restartonuserswitch N -unicodekeyboard 0 -keyboardloading n -pressmodsforkeys n -eventtap 3 -swapbutto

We’ve just posted an updated Vine Server Beta that we hope addresses this problem. Please read this notice –

Thanks for your tenacity. I’ve installed 3.1Beta2 and will post back here if any problems persist.

Thanks again! :smiley:

I remembered to come back and say: it’s still working, after a week straight. That’s fantastic news. :slight_smile: Thanks again for the update! :smiley:

I have one issue. After the upgrade to the beta, i couldnt connect till i changed to display 2 and port 5902…

Previously i had it set for display 1 and port 5901, as i run the apple remote on port 5900…

any ideas why i cant use port 5901?

You are almost certainly already running a VNC server (possibly Vine as a Startup Item) on port 5901.

Thats what i thought. However when i change the vine app from port 5901 to 5902, i can connect to 5902 fine.

Also to see that nothing is running on 5901, i did the following. I telnet to 5900, 5901 and 5902 and here are my results…

imac:~ joe$ telnet localhost 5900
Trying ::1…
Connected to localhost.
Escape character is ‘^]’.
RFB 003.889

^C^CConnection closed by foreign host.
imac:~ joe$ telnet localhost 5901
Trying ::1…
telnet: connect to address ::1: Connection refused
Trying fe80::1…
telnet: connect to address fe80::1: Connection refused
telnet: connect to address Connection refused
telnet: Unable to connect to remote host
imac:~ joe$
imac:~ joe$ telnet localhost 5902
Trying ::1…
Connected to localhost.
Escape character is ‘^]’.
RFB 003.008


So nothing appears to be running on 5901…

Can you guys start a new thread or something?

That is bizarre, a firewall rule perhaps?

It could also be a service that has BOUND the port, but isn’t communicating on it. You can run netstat to see more detailed network statistics.

Regardless I’m pretty sure it’s not a Vine Server on 10.5 issue but rather a networking issue on your machine.

With the release version and System Server turned on with the default settings, I could make a connection to the Mac login screen, select my username and enter a password, but then I lost the connection, as reported in an earlier post.

I then changed to the beta version, but with this (and exactly the same settings) I cannot connect to the login screen. My VNC client says connection timed out. Reading above, I then changed the port to 5902 and the display to 2. With this I still cannot connect, but now it says connection refused, instead of timed-out. If I then login manually to the mac, as soon as I login it comes up with a dialogue box requesting permission to accept incoming connections.

With either the release or beta version, everything works fine if I log in to the mac manually and then start the Vine server.

I’d be glad of any suggestions of how to get this working. Thanks