vine and sudoers file

Right installed vine 3 (the final version). Configured the startup item, was prompted for my admin password, worked fine. Reboot, wanted to disable the built in vnc server, was prompted, strange no user name as default, no problem, entered my id and pwd, denied.

What the …

Went into terminal, sudo , userid not in sudoers file !

So the install messed up my sudoers file, not a very nice thing to do :slight_smile:

No worries, rebooted using DVD and edited the file and added the two users that were supposed to be there.

Just wanted to let you guys know.

The only change was the adding of the startup vine server.

I can guarantee that Vine Server does NOT make any changes whatsoever to the su, sudo, or sudoers files.

I personally use all of those services on a regular basis and would definitely notice if something in there were changed by installing Vine (or configuring the startup item).

You can review all the open source code that comprises Vine Server on Vine Server writes to a few very select places (/tmp, /Library/StartupItems, and /Library/LaunchAgents) but never to anything in the /etc directory.

Yes and I believe you, unfortunately it wasn’t only the sudoers file, I lost any admin ability on my box. After editing the sudoers file, I could again use su or sudo, but all of a sudden the two users who were selected as admin didn’t have admin rights, and I couldn’t add these anymore

Not a major deal, only acrobat updater wouldn’t run anymore because of lack of admin rights. Even Root login didn’t solve that.

I tried to do manual things, like adding users to wheel with the new command tools available in Leopard (there is no netinfo anymore), used the OSX 1.5 server utility to make users admin, but got back an error message, that using google didn’t yield any result.

One thing is for certain, the ony change was the startup item. It might have something to do with the fact that I used a domain user (as in Active direcotry) to do the change, but then again, that’s my normal user, and usually I install programs using that user.

Anyway I decided to restore from time machine, but wasn’t lucky there either, it would stop after about 60% on some .tif file, you would think it would continue, but in good apple tradition, it failed the whole restore :slight_smile:

Anyway, I just reinstalled the OS, and will restore user files from time machine later today.

But no doubt something strange is happening, and again, the only thing I did yesterday was install vine (as in copying the server program to apps, then ran it, and installed the startup item, with Password alternate port then rebooted, Then I wanted to disable the apple vnc server, and noticed that the admin prompt didn’t work properly anymore.

And to add, vine server works perfectly on the newly installed Leopard 10.5.1 :slight_smile:

No issue there.