Unable to generate certain images

When I try to generate a TIG that matches what I see on the screen I get the following error message

*** -[NSCFString keyEnumerator]: selector not recognized [self = 0x71b5830]

However when a colleague connects to the same SUT and tries to find the same image he can find it with no problems? I’m confused as to what to do to to fix this problem. So far I have tried

  1. Using different versions of eggplant 3.3 and 4.0
  2. Removing the com.redstonesoftware.* files in ~/Library/Preferences
  3. Restarting the SUT and my laptop

I could use some help.



Please look inside your .suite folders to see if there are any mal-formed TextPlatforms.plist files. If there are, move those aside and restart Eggplant. Let us know if that solves your problem.

I tried this but it doesnt seem to work. Can I run some diagnostics and send them to you. If yes let m know what would be most useful

First, as a diagnostic measure try to run this code snippet in your script

put the textplatforms
put the currentTextPlatform

and post your results here.

put the textplatforms

(“MacOSX_10.4”:(Generator:(Internal:“Yes”), Name:“MacOSX_10.4”, Styles:(ApplicationMenu:(Bold:“Yes”, TextBackgroundColor:"#F0F0F0", TextColor:"#000000", TextFont:“LucidaGrande”, TextSize:“14”), Default:(TextBackgroundColor:"#FFFFFF", TextColor:"#000000", TextFont:“LucidaGrande”, TextSize:“13”), Finder:(TextBackgroundColor:"#FFFFFF", TextColor:"#000000", TextFont:“LucidaGrande”, TextSize:“12”), InactiveWindowTitle:(TextBackgroundColor:"#F0F0F0", TextColor:"#7D7D7D", TextFont:“LucidaGrande”, TextSize:“13”), Menu:(TextBackgroundColor:"#F0F0F0", TextColor:"#000000", TextFont:“LucidaGrande”, TextSize:“14”), WindowTitle:(TextBackgroundColor:"#E0E0E0", TextColor:"#000000", TextFont:“LucidaGrande”, TextSize:“13”))), WindowsClassic:(Generator:(Host:“Current SUT”), Name:“WindowsClassic”, Styles:(Default:(TextBackgroundColor:"#FFFFFF", TextColor:"#000000", TextFont:“Tahoma”, TextSize:“8”), InactiveWindowTitle:(Bold:“Yes”, TextBackgroundColor:"#8B8B8B", TextColor:"#D0D0D0", TextFont:“Tahoma”, TextSize:“8”), Menu:(Bold:“Yes”, TextBackgroundColor:"#D0D0D0", TextColor:"#000000", TextFont:“Tahoma”, TextSize:“8”), WindowTitle:(Bold:“Yes”, TextBackgroundColor:"#1D3B7B", TextColor:"#FFFFFF", TextFont:“Tahoma”, TextSize:“8”))))

put the currentTextPlatform


Everything here seems to be in order.

So, when you run something like

put imageInfo (Text:"Help", TextStyle:"Menu")

You get an exception? What about in a new script of a new suite?

I have another data point. If I run against a windows machine that has a TIG that you guys released everything works just fine. I’ll check on what you asked me to wrt to the new suite and new script next.

I ran some more experiments and here is what I found

  1. If I create a new suite and a new script things work fine

  2. Running the sam script as in step 1 in the same suite that I am having problems with works fine

  3. Running the failing ImageFound with the same parameters works fine when I use a new script however it still fails when I run it in my main script.

It’s possible for scripts to dynamically modify the TextPlatforms and/or the TextStyles. Somewhere in your script it seems like those might be getting changed. Did you run that earlier snippet in your primary script right before executing the command? You might also review the log file, that should show any changes to the TextPlatforms and/or TextStyles.