UltraVNC and Eggplant

I am unable to open a connection from Eggplant when the UltraVNC is being used as the server. While UltraVNC does have features that aren’t part of the VNC standard, it does seem to be compatible with every VNC client I have used with it other than Eggplant. :frowning:

Would it be possible to try to figure out why the two of them can’t play together? UltraVNC has some very nice features, and it’s performance as a VNC server seems to be quite a bit better than RealVNC.

It appears that there is a problem with the encoding information being sent by UltraVNC when using the Zlib Hextile compression scheme – Eggplant is one of the few VNC clients that prefers this encoding (because we can’t use the Lossy TightVNC encoding) so most people don’t see this bug with UltraVNC.

To disable this encoding on the Eggplant side:
[list]Go to the Eggplant menu and select the Preferences menu option.
Click the VNC toolbar item and deselect the checkbox next to Zlib Hextile (the first item in the list).
The change takes place automatically and immediately – you don’t need to close the panel or take any other action to save the setting.
I was able to connect successfully with any of the other options turned on, but if you still have trouble establishing a connection, just try deselecting them one at a time and trying to connect after you turn each one off.