Strange input issue with Vine 3 and Leopard

When I connect to my mac from my WinXP notebook running UltraVNC’s bundled VNC Viewer or Tight VNC Viewer (or for that matter I imagine any viewer, though I haven’t tried Vine from another mac because I don’t have another mac), I have run into some strange keyboard issues:

If I try to use spotlight, keying “i” or “r” triggers the CMD-letter action for those keys.

For example, if I try to do a spotlight search for “split” for split & concatenate, I type s p l i, but only the s p l register in the spotlight dropdown. Once I type the i, the finder opens the info pane for the first result in my search, which coincidentally enough is the Split & Concat app file.

Regardless of the results, I can’t type the letter “i” or the letter “r” (gets me Reveal in Finder) in a spotlight search while connected with VNC. It’s like the mac thinks my CMD key is held down or something. This behavior does not occur if I interact with the mac desktop directly.

Does anyone have any thoughts?

What keyboards are you using? (On both the viewer and the server side)

Server side I am using a microsoft wireless natural from the wireless optical desktop bundle.

Client side I am using whatever keyboard is built into my thinkpad T60, or a Microsoft Natural 4000 on my desktop.

I do not have the Microsoft keyboard driver loaded on the mac.

Sorry for being ambiguous – what keyboard Layout are you using? Are they both using standard English 101 keyboards layouts?

I believe so - they’re using whatever Windows XP and Vista use as default in a standard US English install.

I’m not using a Dvorak map or anything goofy like that.

I have this ‘i’ and ‘r’ key issue too!

I am connecting from windows XP with vnc viewer and if i hit r in spotlight search, the spot light search just stops!

This is new to v3.0 AFAIK

Using english 101 keys

I encountered the same problem running Vine Server 3.0 on Leopard 10.5.2
from any of the various VNC clients on Windows XP.

I reverted back to Vine Server 2.1 and this seems to work better.

Refer to the work-around detailed in this posting:

which is to put a switch in the preferences > advanced tab
-EventSource 3

I have a strange version of the i issue… sometimes when I hit the i button, more often when I use it with shift, it acts as though the shift key is stuck. Thoughts?